1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

American Broken Horn Calamity

Discussion in 'PC Discussion' started by BlaringHorn, Mar 24, 2021.

  1. BlaringHorn

    BlaringHorn New Member

    Joined:
    Mar 24, 2021
    Messages:
    2
    Likes Received:
    6
    So, I was playing Peninsula Corridor in TSW2, really nice route from what I've played so far. But playing one of the long GP38-2 services, midway through the service the horn stops working (well, the bell still rings) and I am now forced to listen to it blaring at random (?) intervals through the rest of the service (which ended in a rare crash to desktop only a couple of miles from finish to top it all off :mad:).

    Now, I'm already familiar with this horn bug from Sand Patch, so was really disappointed to hear it's not restricted to just that route. So, my question is, will this be fixed? And is it unreasonable to fear the same bug making it's way to Clinchfield? It's so annoying and immersion breaking when it happens, but not using the horn at all would feel the same way.
     
    • Like Like x 3
  2. OsamaBinLiftin

    OsamaBinLiftin Member

    Joined:
    Jan 9, 2021
    Messages:
    54
    Likes Received:
    85
    I have this happen during Dash 8 C40-W services and scenarios on SPG as well, and it's terrible since it removes the horn as a feature effectively for the remainder of the drive after it breaks. Hopefully they can fix this, it's not just on Peninsula Corridor
     
  3. topcat1077

    topcat1077 New Member

    Joined:
    Dec 20, 2020
    Messages:
    17
    Likes Received:
    6
    Well, unfortunately this has been a long suffering issue that DTG has chosen to continue to ignore apparently, since they were into the 8-40C and fixed some issues, but the horn irritation STILL remains. I have stayed away from TS2 since this began, but came back hopeful when I read that issues with the 8-40 had been addressed. Now disappointed again. With all that being said, there is an irritating back door for the horn issue. When it occurs, press the 8 camera (shift + arrow for fast movement), and then zoom it towards the rear of your train, continuing til all sound goes silent, then click the 1 camera to put you back in loco. This action will restore your horn, but don't get happy feet, at some point it will happen again. This is the best work around I'm aware of for this issue until DTG "ever" decides to look into it.
     
  4. davidh0501

    davidh0501 Well-Known Member

    Joined:
    Apr 29, 2020
    Messages:
    507
    Likes Received:
    741
    The B button is the best thing about US routes.
     
    • Like Like x 1
    • Helpful Helpful x 1
  5. BlaringHorn

    BlaringHorn New Member

    Joined:
    Mar 24, 2021
    Messages:
    2
    Likes Received:
    6
    Unfortunately I was right about my fear for Clinchfield, the SD40 is affected with the broken horn syndrome as well, though this time it seems to break faster than ever and curiously there's no random blaring horn afterwards. Fortunately the F7 doesn't seem to be plagued with this?

    You'd think a simple thing such as the horn working when pressing a button would be easy to do, much easier than a lot of other things in a simulator like this for sure? And the fact that it affects old and new routes alike is really frustrating. Have the developers acknowledged this bug in the past? I mean, it's easy to replicate, so they should be able to find the underlying reason?

    Sorry for the rant... :(
     
    • Like Like x 3
  6. topcat1077

    topcat1077 New Member

    Joined:
    Dec 20, 2020
    Messages:
    17
    Likes Received:
    6
    Blaring Horn, I'm fearing the horn calamity has taken a turn for the worst. Haven't been on TSW2 for a couple weeks because the horn issue really drives me away. I go back periodically to check if a fix has magically happened, but always leave disappointed. Anyway went in today and ran Shaw Mine "A" with 8-40CW's, horn fiasco started at the 1st grade crossing beyond Ellerslie. went to the back door, camera 8 to regain horn and now there seems to be a new annoyance, horn use is restored, but now instead of the blaring being gone for whatever period of time it decides, now the fade in fade out is irritatingly constant....and the horn function is actually working. Think I'd dump the whole game if I didn't have so much invested, so I guess I hang on to it and not play, and hope DTG wakes up from their slumber soon. In the mean time, no new purchases for TSW2! I've had enough.
     
    Last edited: Apr 19, 2021
    • Like Like x 1
  7. space_ace96

    space_ace96 Active Member

    Joined:
    Sep 24, 2019
    Messages:
    78
    Likes Received:
    109
    This issue is one of the consequences of the approach of only focusing on fixing bugs that are "gamebreaking". The problem is, with DTG, there will always be gamebreaking bugs, and QOL stuff like this don't get addressed because "well you can still drive the train". I'm wondering if DTG's lack of attention and care to horns comes from the fact that horns are so rarely used in the UK and continental Europe, or at least nowhere near as much as the US. They don't realize that horns matter a lot more to us, partly because US train horns have a culture surrounding them and partly because US trains have to use them constantly. I've seen Matt and others complete ECW only using horn 3 times at the W boards. Meanwhile, if you use your horn properly in Peninsula Corridor, you can easily have 20-40+ blasts depending on how much you use the horn at platforms and stuff.
     
    • Like Like x 3
  8. WaveyDavey

    WaveyDavey Well-Known Member

    Joined:
    Mar 31, 2020
    Messages:
    310
    Likes Received:
    364
    I’ve found it only seems to happen in the SD40 on Clinchfield and then only when the weather is raining or snowing and the wipers are going etc.... meaning there are lots of other sounds going on.

    When driving in the dry where these other wipers and weather related sounds aren’t used the horn seems to work fine in the SD40.
     
    • Like Like x 1
  9. solicitr

    solicitr Well-Known Member

    Joined:
    Jun 20, 2020
    Messages:
    3,746
    Likes Received:
    4,987
    According to most US RRs' operating rules, not only do you have to sound the horn at all whistle posts, level crossings and platforms, and when starting to move, but also when exiting any tunnel, and at any place where a bend or other obstruction reduces down-line visibility to under a quarter mile. That's a LOT of horn blasts! Train whistles in the distance are an ubiquitous part of American life.

    (And I do mean blasts. Not nearly loud enough in-game: go to the rear-end 3 camera and blow the horn: you can't hear it, only half a mile away!)
     
    Last edited: Apr 19, 2021
    • Like Like x 3
  10. geloxo

    geloxo Well-Known Member

    Joined:
    Nov 21, 2018
    Messages:
    719
    Likes Received:
    1,178
    Same here. It´s not a preserved collection issue only therefore, but a game engine issue. I also lost the brakes release sound when the horn was lost. So it´s not related to horn only but to sounds in general. I run game under DX11, so it´s not caused by DX12 or something like that.

    Cheers
     
  11. LeadCatcher

    LeadCatcher Well-Known Member

    Joined:
    Dec 9, 2016
    Messages:
    932
    Likes Received:
    2,136
    This is one of the biggest grips I have with TSW2 is the horn becoming either dis-associated from the train or not working at all. I won’t throw my toys out of the pram over it, but do wish it would get fixed. As others have stated, in North America, the horns are used A LOT. Growing up in the Southwest, many a summer night, went to sleep listening to the “ lonesome whistle” of a freight going through the small town that I grew up in.
     
    Last edited: Apr 19, 2021
    • Like Like x 2
  12. roysto25

    roysto25 Member

    Joined:
    May 1, 2019
    Messages:
    39
    Likes Received:
    41
    If TSW2 sounds are in any way similar to TS, there seem to be limits on the number of simultaneous sounds which can be used. Searchlight Simulations ran into this in their building of their AC4400 for TS - incidentally probably the most accurate version of any US loco - they specifically warn that certain sounds may be lost or reduced at times due to limits of the sim engine. Maybe Unreal has the same issue and there is some dynamic balancing needed of the sound setup.
     
    • Like Like x 1
  13. Dinosbacsi

    Dinosbacsi Well-Known Member

    Joined:
    Sep 20, 2017
    Messages:
    831
    Likes Received:
    1,541
    From what we know, that is the case indeed. Once in a stream Matt has noticed that the alerter sound on his train occasionally didn't make any sound. His first guess was that the game was out of sound channels to use and so the sound effect didn't play.
     
  14. stujoy

    stujoy Well-Known Member

    Joined:
    Aug 29, 2019
    Messages:
    3,449
    Likes Received:
    8,078
    It’s not just horn sounds that mess up. I got the sound of a level crossing stuck in my cab on one run on Pen Corridor. Endlessly repeating. It was a nightmare as it was quite early on in an all stops service. The sound on that route is particularly messed up but the horn issue is a big problem all over TSW2.
     
  15. Crosstie

    Crosstie Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    1,054
    Likes Received:
    1,665
    I live very close to a busy freight line and I hear that "lonesome whistle blow" pretty much 24/7, so I'm very tuned in to American horns. The "horn problem", in all its varieties, is very irritating, especially on SPG and, now CRR. It's not a game breaker, but, considering that it goes back at least to the beginning of TSW2, has gotten zero traction and is nowhere on the roadmap for any loco, don't expect any improvement in the foreseeable future.
     
  16. solicitr

    solicitr Well-Known Member

    Joined:
    Jun 20, 2020
    Messages:
    3,746
    Likes Received:
    4,987
    Try this: use the 8 camera and fly about 400 yards away, then blow the horn. You can't hear it! At less than a quarter-mile!
     
  17. Crosstie

    Crosstie Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    1,054
    Likes Received:
    1,665
    Oftentimes, I can barely hear it in the cab, even with a window open. Sometimes it won't stop, or it disappears into the who knows where and then reappears unbidden a few miles later. It's really quite amusing until it's not.
     
  18. JustWentSouth

    JustWentSouth Well-Known Member

    Joined:
    Nov 27, 2019
    Messages:
    365
    Likes Received:
    780
    I am enjoying the F7 horn more and more an I am glad it doesn’t wander like the SPG horn on the SD40. Will this be fixed for the SD40 when its official horn arrives? For those who have them, does this bug happen with horn mods?
     
  19. solicitr

    solicitr Well-Known Member

    Joined:
    Jun 20, 2020
    Messages:
    3,746
    Likes Received:
    4,987
    Yes. The mod just replaces the sound file, it doesn't control when (and if) it plays
     
    • Like Like x 1
  20. space_ace96

    space_ace96 Active Member

    Joined:
    Sep 24, 2019
    Messages:
    78
    Likes Received:
    109
    I just hope they get this fixed somehow before they take another crack at a US passenger route. It may not be as big of an issue in something like the NEC which is grade separated and only really uses the horn when starting to move or going express through a station, but if they choose a passenger line with multiple stations and crossings, having a horn break like that will just kill immersion for those of us who want to use it properly. They also really need to sort out their sound mixing because US horns are loud as hell. I've had an express NICTD South Shore train go express through a station with a narrow platform blast it's horn on a hot summer day while I'm standing about 20 feet away and I could see the distortion in the air from the soundwaves. All I could hear was horn. No motor sounds, no cars driving, no people talking--when that horn blew, it's volume swallowed every other sound in the area. I know UK and German horns aren't nearly that loud, but they really need to fix the way they mix US horns. Even with the F7, I can be in camera 8, hit the horn, and the idling engine is still able to be heard over the horn.
     
    • Like Like x 1
  21. Thorgred

    Thorgred Member

    Joined:
    Jun 8, 2018
    Messages:
    61
    Likes Received:
    34
    see if adding maxchannels helps in engine.ini
    i have been using that one almost since start of tsw 1

    [Audio]
    UnfocusedVolumeMultiplier=1.000000
    MaxChannels=96
     
  22. WaveyDavey

    WaveyDavey Well-Known Member

    Joined:
    Mar 31, 2020
    Messages:
    310
    Likes Received:
    364
    I assume you don’t have the horn and other sounds disappearing issue using this technique then?
     
  23. Thorgred

    Thorgred Member

    Joined:
    Jun 8, 2018
    Messages:
    61
    Likes Received:
    34
    i never noticed disapearing horn sounds
     
  24. WaveyDavey

    WaveyDavey Well-Known Member

    Joined:
    Mar 31, 2020
    Messages:
    310
    Likes Received:
    364
    I’ll give it a try and see if it improves the issue.
     
  25. WaveyDavey

    WaveyDavey Well-Known Member

    Joined:
    Mar 31, 2020
    Messages:
    310
    Likes Received:
    364
    I can now confirm this setting makes no difference..... I've just had the horn stop working again.

    Using the technique above with the '8' view gets it back again still.
     
    • Like Like x 1

Share This Page