Black Mountains And Black Ground Texture Problem In The Distance, How To Finally Fix It?

Discussion in 'Technical Reports' started by pasictarik10, Sep 7, 2020.

  1. pasictarik10

    pasictarik10 Member

    Joined:
    Jul 24, 2019
    Messages:
    130
    Likes Received:
    13
    For a while now, I've had problems with black mountains and black ground texture in the distance on most routes. I have no idea how to fix it or what the problem is. Whenever there is a route with a lot of mountains, it gets even worse. I tried to toggle field of view, ambient occlusion, depth of field etc. and change settings to see if it improves anything but it doesn't. Could it be an anti-aliasing or texture filtering issue? Here are two pictures so you can see for yourself. Any help would be greatly appreciated!!
     

    Attached Files:

  2. Peter Hayes

    Peter Hayes Well-Known Member

    Joined:
    Dec 9, 2016
    Messages:
    657
    Likes Received:
    266
    What video card are you using?
    Drivers up to date?
    What monitor - are you using the windows default/native/recommended resolution in TS20XX?
    Have you tried resetting the video settings:
    Close TS and Steam and navigate to
    \STEAM\steamapps\common\RailWorks\Content and delete/rename the playerprofiles.bin file.
    Restart Steam and then TS 2020 allowing the latter to rebuild the graphics/monitor settings file.
    If this works and TS 2020 opens, then reset your graphics/monitor settings within TS 2020.
     
  3. pasictarik10

    pasictarik10 Member

    Joined:
    Jul 24, 2019
    Messages:
    130
    Likes Received:
    13
    I don't know what the windows default/native/recommended resolution in TS20XX is.

    I really need to make sure I don't do something stupid I can't go back on if I do what you're suggesting. I edited a lot of routes, I don't want to lose everything.

    Everything is up to date, I posted about my computer specs a few months ago on this forum.
     
    Last edited: Sep 10, 2020
    • Like Like x 1
  4. 749006

    749006 Well-Known Member

    Joined:
    Dec 10, 2016
    Messages:
    6,591
    Likes Received:
    2,008
    https://www.howtogeek.com/119117/ht...your-monitors-native-resolution-is-important/
    So someone who is trying to help you should look back thru your old posts because you are too lazy to the info again?

    Why should we help you if you cannot help us?
     
  5. triznya.andras

    triznya.andras Well-Known Member

    Joined:
    Jun 29, 2019
    Messages:
    667
    Likes Received:
    1,050
    Have you experimented with weather choice?
    It, or its details might cause similar things. Not really while playing, but more in the editor.
    Other than that, I've no idea. Looks like a distance blur to me, thinking it's dark, its settings being useful in foggy, rainy weather.
     
  6. pasictarik10

    pasictarik10 Member

    Joined:
    Jul 24, 2019
    Messages:
    130
    Likes Received:
    13
    I have that problem in every weather choice, it's more noticeable in sunny weather because skies are clear but either way it's a recurrent problem on most routes as was my sun problem which I still haven't solved.
     
  7. RGoo

    RGoo Member

    Joined:
    Mar 7, 2020
    Messages:
    49
    Likes Received:
    14
    Do you have anti- aliasing on? That used to happen to me when it was off. Even if you have it on the lowest setting other than off it gets rid of the issue
     
  8. pasictarik10

    pasictarik10 Member

    Joined:
    Jul 24, 2019
    Messages:
    130
    Likes Received:
    13
    So I would have to have anti-aliasing on then?
     
  9. RGoo

    RGoo Member

    Joined:
    Mar 7, 2020
    Messages:
    49
    Likes Received:
    14
    I’m sorry I just realised I made an error. Sorry. You would need Dynamic Lighting on, as that enables a smoother fade between the foreground and background. Anti- Aliasing would still be helpful though as it would smooth out the jagged lines in the background
     
  10. pasictarik10

    pasictarik10 Member

    Joined:
    Jul 24, 2019
    Messages:
    130
    Likes Received:
    13
    If I switch around anti-aliasing, it just creates weird black and white flashes all over on my computer screen as if the screen was damaged. However, maybe there's a specific set of anti-aliasing. As for Dynamic Lighting I will try it but as I recall then the whole route becomes way too bright as if it was a Lego game.
     
  11. pasictarik10

    pasictarik10 Member

    Joined:
    Jul 24, 2019
    Messages:
    130
    Likes Received:
    13
    This isn't a Contrast issue, I already explained that. Adapative Bloom is turned off.
     
  12. dbrunner#4864

    dbrunner#4864 Well-Known Member

    Joined:
    Mar 25, 2021
    Messages:
    263
    Likes Received:
    381
    Also have the same issue on multiple routes from Pacific Surfliner, Arosa , Rsslo stuff. Never found a fix. I believe it only occurs on AMD video cards.
    Any updates on the matter , possible fix ?
     
  13. torfmeister

    torfmeister Well-Known Member

    Joined:
    Nov 10, 2021
    Messages:
    1,598
    Likes Received:
    659
    NVidia GTX 1050 Ti, no issues.
     
  14. dbrunner#4864

    dbrunner#4864 Well-Known Member

    Joined:
    Mar 25, 2021
    Messages:
    263
    Likes Received:
    381
    Ty for the reply.
    Anyone with an AMD card can comment if the issue with dark distant terrain also occurs on his side?
     
  15. torfmeister

    torfmeister Well-Known Member

    Joined:
    Nov 10, 2021
    Messages:
    1,598
    Likes Received:
    659
    As you've bumped an almost two year old thread, you're most likely the only one experiencing this. I recommend upgrading your GFX card.
     
  16. Michael Newbury

    Michael Newbury Well-Known Member

    Joined:
    Dec 11, 2016
    Messages:
    3,706
    Likes Received:
    3,031
    I have a AMD card and having no issues.
     
  17. dbrunner#4864

    dbrunner#4864 Well-Known Member

    Joined:
    Mar 25, 2021
    Messages:
    263
    Likes Received:
    381
    My RX5700 blasts away all curent gen games on Ultra without any issues. No need to upgrade yet especially since for the price I payed for this you now get a low end card.

    Can you please tell me what driver version are you using and what card . I wonder if it's a driver related thing.
     
  18. Michael Newbury

    Michael Newbury Well-Known Member

    Joined:
    Dec 11, 2016
    Messages:
    3,706
    Likes Received:
    3,031
    I am using a RX570 with current driver version 22.6.1.
     
  19. dbrunner#4864

    dbrunner#4864 Well-Known Member

    Joined:
    Mar 25, 2021
    Messages:
    263
    Likes Received:
    381
    Thanks a lot for the information provided!

    Now that I know this issue is only on my side and not a generic problem I can try to troubleshoot again

    I wonder if also a corrupted ground texture/ asset might be causing this on all routes, but it would be a real pain to find out which one it is
     
    • Like Like x 1
  20. dbrunner#4864

    dbrunner#4864 Well-Known Member

    Joined:
    Mar 25, 2021
    Messages:
    263
    Likes Received:
    381
    Tried reinstalling the game and the latest video driver. Still same issue

    the issue is caused by dynamic lights. It doesn't mater what weather you have, when you load the map half the terrain will be in complete darkness until you approach it like 1 km away and than the normal textures will appear around the camera. This is such a weird thing, when traversing such dark terrain area, only the terrain in a certain radius around the train is being lit and rendered properly the rest is pitch black.

    I might need to raise a new thread on this, but i'm still puzzled why this occurs on a modern AMD card. Must be something with the way dynamic light interacts with the environment.
     

Share This Page