PC Boston Sprinter, Mid-game Ue4 Crashes

Discussion in 'Technical Reports' started by EchoKilo, Aug 28, 2021.

  1. EchoKilo

    EchoKilo Member

    Joined:
    Jun 4, 2017
    Messages:
    73
    Likes Received:
    55
    It seems to be difficult to get rid of the game crashing while driving. I tried to drive a Boston to Stoughton service twice, both times it ended in a UE4 Crash at slightly different locations.

    In both cases, the weather was set at clear, no mods, no custom liveries or scenarios installed. Running on i7/7700 with 16GB or RAM and GTX1070 (8GB). Graphic settings are "High" except shadows on "Medium" and view distance quality at "Ultra". Steam file verification done (again) and no problems were found.

    I never experienced any crashes before the 4.26 update.

    I have the crash logs available, if someone is interested.


    Crash #1:
    Crashed when approaching Canton Center station from Canton Junction direction, just 10 yards or so before coming to a full stop (speed at that time around 5 mph).

    LoginId:6648facc47e5317eaa6ba5853eb6a982
    EpicAccountId:

    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffffffffffff

    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    kernel32
    ntdll


    Crash #2:
    Crashed when approaching Canton Junction station, about 500 yards to go, from Boston direction. Driving MBTA service #913 from Boston to Stoughton (timetable mode).

    LoginId:6648facc47e5317eaa6ba5853eb6a982
    EpicAccountId:

    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffffffffffff

    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    TS2Prototype_Win64_Shipping
    kernel32
    ntdll
     
  2. conniethunder

    conniethunder Well-Known Member

    Joined:
    Feb 13, 2020
    Messages:
    325
    Likes Received:
    264
    There are a number of other posts reporting similar issues, my self included.
    We thought it was down to a certain loco and/or 16MB of RAM or less, but that's now not the case.
    ATM, it still appears to be random.
     
    Last edited: Aug 29, 2021
  3. EchoKilo

    EchoKilo Member

    Joined:
    Jun 4, 2017
    Messages:
    73
    Likes Received:
    55
    Thanks for your reply. Yes, I've been trying to follow the other threads as well. For me, so far all in-game crashes have happened at or near Canton Junction (give or take few miles at max) while driving the F40PH-3C. I can't recall any crashes happening while driving the cabcar or ACS-64.

    I forgot to mention it in my original message, but I have also never overclocked either CPU or GPU, or any other of my PC's components.
     
  4. Geth_2234

    Geth_2234 Well-Known Member

    Joined:
    Sep 20, 2020
    Messages:
    203
    Likes Received:
    289
    It appears to be random with the only pattern I’ve noticed is it appears to happen at some point on the route but in timetable mode, I’m unable to complete any of the services I’ve tried as it crashes each time
     
  5. EchoKilo

    EchoKilo Member

    Joined:
    Jun 4, 2017
    Messages:
    73
    Likes Received:
    55
    Decided to try a different service today, and the game crashed when departing Canton Junction station heading to Stoughton,
    driving F40PH-3C on a journey mode service (MBTA Stoughton #925). I had just gotten speed up to about 10 mph after leaving the station, when the crash happened. Settings etc. are the same as my previous drives. It seems that crashing is only happening with F40PH-3C, I have had no problems when driving the CTC-3 cabcar or ACS-64.

    I have no launch options set, no ini-file modifications, no community made mods or any other customizations. Currently using Nvidia driver version 471.68 (released on 08/10/2021).

    Next I'll have to try to test specifically whether it crashes on services heading to Providence as well.


    LoginId:6648facc47e5317eaa6ba5853eb6a982
    EpicAccountId:

    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x000000000000002e

    nvwgf2umx
    nvwgf2umx
    nvwgf2umx
    nvwgf2umx
    nvwgf2umx
    nvwgf2umx
    nvwgf2umx
    kernel32
    ntdll
     
  6. EchoKilo

    EchoKilo Member

    Joined:
    Jun 4, 2017
    Messages:
    73
    Likes Received:
    55
    Tried to run a Boston to Providence service (MBTA Providence #815) a couple of times. Both ended prematurely in an UE4 crash. On the first try, I got as far as Boston Back Bay, on the second time the game crashed when I reached Ruggles. Both times I was few hundred yards away from coming to a full stop.

    To recap, I have no launch options, no ini-file modifications, no community made mods or any other customizations. I am currently using the latest Nvidia driver, version 471.68 (released on 08/10/2021).

    I have had Steam to verify my game files again, and no problems were found.

    My system specs:
    Intel i7/7700 with 16GB or RAM and Nvidia GTX1070 (8GB), no overclocking.

    Crash #1:

    Fatal error!

    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffffffffffff

    0x000000014154ac0f TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415421bf TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415389b6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014154aa9b TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415421bf TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415420be TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001413f1889 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141541f92 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014279953b TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014082843e TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141042bee TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141047fd6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410480c0 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410480c0 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014104dfd6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410487a1 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001408d80a3 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001408d7162 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014122f801 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141231b7c TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014137cd77 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141378281 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00007fff399a7034 KERNEL32.DLL!UnknownFunction []
    0x00007fff3b142651 ntdll.dll!UnknownFunction []

    Crash in runnable thread TaskGraphThreadHP 8



    Crash #2:

    Fatal error!

    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffffffffffff

    0x000000014154ac0f TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141548617 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415421bf TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415389b6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014154aa9b TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415421bf TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415420be TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001413f1889 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141541f92 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014279953b TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014082843e TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141042bee TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141047fd6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410480c0 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410480c0 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014104dfd6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410487a1 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001408d80a3 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001408d7162 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014122f801 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141231b7c TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014137cd77 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141378281 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00007fff399a7034 KERNEL32.DLL!UnknownFunction []
    0x00007fff3b142651 ntdll.dll!UnknownFunction []

    Crash in runnable thread TaskGraphThreadHP 9
     
  7. conniethunder

    conniethunder Well-Known Member

    Joined:
    Feb 13, 2020
    Messages:
    325
    Likes Received:
    264
    New drivers have just been released.
    I'd also suggest dropping your graphics settings down a notch as people have reported that this helped to complete scenarios without crashes.
     
  8. EchoKilo

    EchoKilo Member

    Joined:
    Jun 4, 2017
    Messages:
    73
    Likes Received:
    55
    Thanks for your reply. Geforce Experience actually notified me of the new drivers being available literally a few minutes before I read your reply. Installed them and I'm going to do some testing later to see if things have improved. If I still experience crashes, then I'll try to reduce my graphic settings further. Don't know what would make the F40PH-3C more demanding graphics vice than the other locos, though.
     
  9. conniethunder

    conniethunder Well-Known Member

    Joined:
    Feb 13, 2020
    Messages:
    325
    Likes Received:
    264
    If it works with lower settings though, at least we'll know where everyone's problems lie.
    Hopefully DTG can then narrow this bug down further as it obviously lies with the UE 4.26 code and maybe with that particular loco.
     
  10. EchoKilo

    EchoKilo Member

    Joined:
    Jun 4, 2017
    Messages:
    73
    Likes Received:
    55
    I have now done three runs with the F40PH-3C after installing the new GeForce 471.96 driver which was released today. I drove the same two services which were prone crash every time (MBTA Stoughton #925 and MBTA Providence #815), plus one additional service I had never tried before (MBTA Stoughton #909). I was able to run all three of them from start to finish without an issue. I want to do bit more testing before I'm ready to declare that the crashing issues are now a thing of the past, but it's looking very promising so far.
     
    Last edited: Sep 1, 2021
    • Like Like x 1
  11. Michael Newbury

    Michael Newbury Well-Known Member

    Joined:
    Dec 11, 2016
    Messages:
    3,702
    Likes Received:
    3,030
    I had a crash running the Cold As Ice scenario just as I was departing from Canton Junction, ran it a second time and managed to complete it with no crashes.
     
  12. ajwilson1889

    ajwilson1889 Active Member

    Joined:
    Aug 22, 2020
    Messages:
    97
    Likes Received:
    101
    Same for me, took 3 attempts to complete without a crash, fortunately it crashed 10 mins in rather than 60 mins in
     
  13. EchoKilo

    EchoKilo Member

    Joined:
    Jun 4, 2017
    Messages:
    73
    Likes Received:
    55
    Unfortunately the crashes are still not totally eliminated. They seem less frequent, but still happening. This time, the game crashed when coming to stop at Sharon station with less than 10 yards remaining, with speed about 5 mph and decreasing. Driving MBTA F40PH-3C towards Providence (timetable mode, about 7:28 departure from Boston). This was a first crash since updating to Nvidia driver version 471.96.

    I need to do more testing/troubleshooting over the coming weekend.


    Fatal error!

    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x000000654465a04c

    0x000000014154ac0f TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415421bf TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415389b6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014154aa9b TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415421bf TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001415420be TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001413f1889 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141541f92 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014279953b TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014082843e TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141042bee TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141047fd6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410480c0 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410480c0 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410480c0 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410480c0 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014104dfd6 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001410487a1 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001408d80a3 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00000001408d7162 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014122f801 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141231b7c TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x000000014137cd77 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x0000000141378281 TS2Prototype-Win64-Shipping.exe!UnknownFunction []
    0x00007fff399a7034 KERNEL32.DLL!UnknownFunction []
    0x00007fff3b142651 ntdll.dll!UnknownFunction []

    Crash in runnable thread TaskGraphThreadHP 6
     
  14. conniethunder

    conniethunder Well-Known Member

    Joined:
    Feb 13, 2020
    Messages:
    325
    Likes Received:
    264
    Anyone experiencing crashes both in game and when exiting:

    Do you have an nvidia GPU?
    Did you try the latest GeForce 471.96 drivers?
    Have you tried lowering your graphics settings in game?

    I'm not trying to take away any fault/s that may lie with the game, but it would be good to get more data regarding drivers and settings, etc. People need to remember that the UE update is probably putting more demand on your same GPU, and so lowering the settings a little 'may' help. :)
    Other than this, I'm out of suggestions.

    @EchoKilo
    A GTX1070 might not be up to any kind of High or Ultra settings, so I still think this will be your problem. I lowered my RTX3060 from Ultra down to high and 'luckily' / 'touch wood', haven't had an in game crash since, only the occasional exit game one.
     
    Last edited: Sep 2, 2021
  15. EchoKilo

    EchoKilo Member

    Joined:
    Jun 4, 2017
    Messages:
    73
    Likes Received:
    55
    I'm not so sure that the GTX1070 or the settings I'm using are the problem here. I have over 500 hours of playing time in TSW2 with the current settings and hardware setup, and never had a crash apart from this one loco on this one route. Even the other locos on this very same route (which I do like, btw!) perform rock solid.
    If it was a matter of the GTX1070 not being able to cope with it, I should be seeing frame rate problems and instability/crashes on other route/loco combinations. However, the frame rates are smooth at 50~60 fps, with a dip to 35~40 fps at busier stations. Hardly a sign of an insufficient performance. I'd be interested in hearing experiences from other GTX1070 users, including what settings they're running the sim with.
    If Boston Sprinter is more demanding on the hardware as route, then why I'm not seeing problems with the CTC-3 or ACS-64? The F40PH-3C does not look or feel like an overly complex locomotive (in sense of hardware requirements) compared to the other two.

    Anyway, I just finished another successful F40PH-3C run (MBTA Providence #803), and this time I was tracking the VRAM usage while driving. The game used barely a half of the 8 GB that my GTX1070 has, so it's not even close to running out of VRAM either. At least not when everything is working correctly, that is. Will be interesting to see if I can see any difference if/when another crash happens.
     
  16. Pinguinie

    Pinguinie Active Member

    Joined:
    Oct 20, 2020
    Messages:
    116
    Likes Received:
    106
    Same with

    Chapter 2 Route 1

    Just before you get to the penultimate task: "Drive over a place" crashes the game.
    (between 4,5 - and 4,1 kilometer)
    PC
     
    Last edited: Sep 3, 2021
  17. conniethunder

    conniethunder Well-Known Member

    Joined:
    Feb 13, 2020
    Messages:
    325
    Likes Received:
    264
    I've just run that timetable - MBTA Providence #807
    Gigabyte RTX3060 OC 12 GB @
    nVidia drivers 471.96 (31/08/2021)
    EDIT: 1080p (1920x1080)
    High settings
    100% scaling
    Capped at 60FPS
    VSync On

    ...and had no problems.
    [​IMG]

    I'm still suggesting that you lower your GPU settings IF you want to play the game without crashes UNTIL DTG fix this issue.
     
    Last edited: Sep 3, 2021
  18. Jannerdunk

    Jannerdunk Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    330
    Likes Received:
    652
    Great, just had a new PC delivered. Installed TSW2 and now I've got random in game crashes! Guess it's back to the old PC for the moment until dovetail sort the issue
     
  19. Bertil Persson

    Bertil Persson Active Member

    Joined:
    Aug 23, 2017
    Messages:
    200
    Likes Received:
    105
    I also have this crash. I'm adding my answer, so they can see that it's common on PC.
     

Share This Page