1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pretty Graphics + High Framerate | Settings For Gtx970 Or Better

Discussion in 'PC' started by Ding, Nov 4, 2018.

  1. Ding

    Ding New Member

    Joined:
    Oct 30, 2018
    Messages:
    8
    Likes Received:
    18
    Hi everyone,

    I spent a couple of hours this weekend trying to optimize the graphics and the performance of TSW. The game looked pretty decent on my rig but I had issues with jittery anti-aliasing (especially far away objects).

    This is technically fixable by increasing the resolution scale to 150-200% - however this will have a massive impact on your framerate (images per second your graphics card can render).

    My goal was to get a really decent overall image with only minimal performance impact while keeping the resolution scale at 100%. I came up with what I feel are good settings and I wanted to share them with you.

    For reference, my computer has the following components built in:
    CPU: Intel Core i7-5820K (overclocked to 4.00 GHz)
    RAM: 16 GB DDR4
    VGA: NVIDIA GeForce GTX970 (4 GB, stock clock)
    SSD: Samsung M.2

    In order to make it work you have to edit two sets of settings:
    1. Graphics settings in TSW
    2. Graphics settings for TSW in the NVIDIA driver (will get rid of jittery anti-aliasing!)

    I'll start with the settings for TSW (for reference see attached screenshot - sorry for German):
    Basic settings:
    Antialiasing: TAA
    Percentage: 100%
    Advanced settings:
    Foliage: Ultra
    Shadows: High
    Effects: Medium
    Post-Processing: Ultra
    View Distance: Ultra
    Textures: Medium

    Now go into the NVIDIA driver settings and edit the settings for TSW (to get there open NVIDIA control panel, pick "Manage 3D settings" on the left, click on the "Program Settings" tab and select TSW. If it's not there click "Add" and it should pop up under "Recently Used"):

    Anisotropic filtering: 16x
    Antialiasing - FXAA: On
    Antialiasing - Gamma correction: On
    Antialiasing - Mode: Enhance the application setting
    Antialiasing - Setting: 8x
    Antialiasing - Transparency: 8x (supersample)

    See attached screenshot for reference.

    I also attached some screenshots how the game will look like. You might have some overly smooth fonts going on in the menu but otherwise it should run well with much smoother edges at a high framerate.

    I am hitting about 45-60 FPS with these.

    Last but not least here is my GameUserSettings.ini if you just want to copy and paste it (warning: will overwrite all your settings except the key binds) - this file goes into C:\Users\your_user\Documents\My Games\TS2Prototype\Saved\Config\WindowsNoEditor:

    [ScalabilityGroups]
    sg.ViewDistanceQuality=3
    sg.AntiAliasingQuality=3
    sg.ShadowQuality=3
    sg.PostProcessQuality=3
    sg.TextureQuality=1
    sg.FoliageQuality=3

    [/Script/TS2Prototype.TS2GameUserSettings]
    FullscreenMode=1
    LastConfirmedFullscreenMode=1
    FoliageQuality=3
    ShadowQuality=3
    TextureQuality=1
    ViewDistanceQuality=3
    PostProcessQuality=3
    OverallQualityLevel=3
    MouseSensitivity=0.100000
    DisableJunctionDerail=False
    ScreenShotQuality=0
    Measurement=Metric
    GradeUnit=Percentage
    TemperatureUnit=Celsius
    ShowObjectiveMarker=False
    ShowObjectiveStopAtMarker=True
    ShowSpeedLimitMarker=False
    ShowNextSignalMarker=False
    ShowNextSignalAspectMarker=False
    ShowSpeedLimitScreen=False
    ShowNextSignalScreen=False
    ShowScenarioMarker=True
    ShowCompass=True
    ShowScore=True
    CursorType=Medium
    UsingController=False
    UsingKeyboard=False
    InvertedYAxis=False
    QuickWalk=False
    ForceFeedback=False
    QualityLevel=0
    MaxFPS=62.000000
    MasterSoundVolume=1.000000
    MusicSoundVolume=1.000000
    SFXSoundVolume=1.000000
    AmbienceSoundVolume=1.000000
    DialogueSoundVolume=1.000000
    ExternalAlertVolume=1.000000
    MenuSFXVolume=1.000000
    WindowFocus=True
    Subtitles=True
    KeyboardCulture=00000407
    PreferredFullscreenMode=1
    AudioQualityLevel=0
    FrameRateLimit=0.000000
    LastRecommendedScreenWidth=-1.000000
    LastRecommendedScreenHeight=-1.000000
    LastCPUBenchmarkResult=-1.000000
    LastGPUBenchmarkResult=-1.000000
    LastGPUBenchmarkMultiplier=1.000000
    bUseHDRDisplayOutput=False
    HDRDisplayOutputNits=1000

    [/Script/Engine.GameUserSettings]
    bUseDesiredScreenHeight=False
     

    Attached Files:

    • Useful Useful x 9
  2. Shaun123

    Shaun123 Member

    Joined:
    Jan 22, 2018
    Messages:
    31
    Likes Received:
    17
    Excellent post!

    Again I have the same issues as yourself, I recently upgraded my PC this year and TSW runs like a dream, looks spectacular, frame rate is good.

    My specs are:

    Radeon RX 580 Series
    AMD Ryzen 7 1700 Eight-Core Processor
    Asus AM4 PRIME X370 PRO Motherboard
    8GB Ram
    Windows 10 64bit.

    But the anti-aliasing issue is a massive bugbear, jelly cab, flickering/shimmering objects/overheard wires etc.

    Anyone optimised their AMD settings for TSW, that would care to share?
     
  3. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    429
    Likes Received:
    777
    Are you talking about when the train is stationary? It’s a known bug and has been there since day one. It’s infuriating!

    Out of interest what frame rate are you getting vs resolution & settings? I’ve got an RX580 so would be interested in the comparison.
     
    Last edited: Nov 24, 2018
  4. Puffing Nora

    Puffing Nora Guest

    If you set Effects to low you can stop annoying sleeper chair pop in without losing detail.
    Also the engine.ini adhustments are worth a look.
    Try TAA to remove flickering.
     
  5. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    429
    Likes Received:
    777
    Do you know if there’s still a way to get rid of the over brightness in Heavy Haul? There used to be an engine.ini adjustment but it doesn’t seem to work anymore.

    TAA is on. There is zero flickering until the train stops at a station, then this AA texture flickering starts. It’s a known bug and it really spoils the experience :-(
     
    Last edited: Nov 24, 2018
  6. Shaun123

    Shaun123 Member

    Joined:
    Jan 22, 2018
    Messages:
    31
    Likes Received:
    17
    I’ve watched YouTube videos and some setups the flickering seems less prominent if any at all, so thought it was my setup!

    However I’ve tried to push my PC to the max and increase screen percentage to 175% and have seen little drop in FPS and it actually looks better, the flickering is still there but less noticeable.
     
  7. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    429
    Likes Received:
    777
    It depends on what resolution you’re using to begin with. I've got mine set to 2560x1440 so increasing the screen percentage would push it to something crazy so it's not really an option. I reckon in your case it’s the higher resolution that is making the flickering look better, but it's still there sadly.
     
    Last edited: Nov 25, 2018
  8. rwaday

    rwaday Active Member

    Joined:
    Dec 12, 2016
    Messages:
    155
    Likes Received:
    54
    It seems that TSW HH has become the red headed stepchild here. I use color correction through the NVIDIA control panel to make it a bit better. Do not save these settings it will bork all other game colors or even other routes within TSW. By not saving it is only for that session that you are playing.
     

Share This Page