1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PlayStation Scenario Planner Bug

Discussion in 'Technical Reports' started by Nick Y, Feb 11, 2021.

  1. Nick Y

    Nick Y Well-Known Member

    Joined:
    Nov 13, 2020
    Messages:
    973
    Likes Received:
    844
    So, today I've tried adding extra consists into the scenario planner that will run in the opposite direction to the one I am playing.
    On NTP and TVL, those consists are stuck at their start points due to red lights. They are set as passenger services and have staggered start points and start times across the route.
    Each time I've tried to play the routes, those services have stayed stationary and are still there long after their service start times.
    I have even gone back in and edited the routes several times and each produces the same outcome.

    I know Matt did a stream on Monday using NTP in the scenario planner (on PC) and all his extra consists/services ran but I cannot get them to run on PS4.
     
  2. L89

    L89 Well-Known Member

    Joined:
    Apr 8, 2020
    Messages:
    1,118
    Likes Received:
    749
    Try using the bay platform path in TVL. i think I had issues with the other path.
     
  3. Nick Y

    Nick Y Well-Known Member

    Joined:
    Nov 13, 2020
    Messages:
    973
    Likes Received:
    844
    It doesn't work.
    Here's the set up.

    I'm playing as a class 166 3 car from Saltburn to Darlington at 09:50.
    Other programmed trains are running eastbound at various times and are all set as passenger services.
    Class 166 (3 car) Darlington (P4) - Saltburn 09:10
    Class 166 (3 car) Darlington (P3) - Saltburn 09:30
    Class 101 (4 car) Middlesbrough (P2b) - Saltburn 09:40 (bay platform path)

    All the above have red lights and do not move.
     
  4. AGoodJudge

    AGoodJudge Active Member

    Joined:
    Aug 29, 2020
    Messages:
    107
    Likes Received:
    57
    The AI services have to be scheduled to start after the player service, otherwise they never move and have permanent red signals. That seems to be regarded as a feature of scenario planner rather than a bug, so it wasn't corrected in the latest fix.
     
    • Helpful Helpful x 1
  5. Nick Y

    Nick Y Well-Known Member

    Joined:
    Nov 13, 2020
    Messages:
    973
    Likes Received:
    844
    Thank you for your help. Starting the AI services later worked and I did see them on the route whilst driving.
     
    • Like Like x 1

Share This Page