1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The Sound Looping Bug

Discussion in 'Off Topic' started by brfan#9132, May 30, 2021.

  1. brfan#9132

    brfan#9132 Active Member

    Joined:
    Jan 4, 2021
    Messages:
    182
    Likes Received:
    90
    The sound looping is starting to annoy me I just want it fixed if it is annoying you tell me why and what route
     
    • Like Like x 2
  2. junior hornet

    junior hornet Well-Known Member

    Joined:
    Oct 15, 2018
    Messages:
    820
    Likes Received:
    1,262
    It’s not a bug. It’s a feature. :)
     
  3. NYIslanders0902

    NYIslanders0902 Active Member

    Joined:
    Sep 11, 2020
    Messages:
    113
    Likes Received:
    56
    Yes it is a bug, because I’m literally getting the same problem as well, I’m hearing a bunch of cracking and popping noises whenever I drive on certain routes, that ain’t no feature.
     
  4. eire007

    eire007 Active Member

    Joined:
    Apr 7, 2020
    Messages:
    154
    Likes Received:
    183
    Ever since the move to TSW2 this has been an issue. If you leave a camera angle for long at the engine it starts looping. It’s a shocker.
     
  5. Maik Goltz

    Maik Goltz Well-Known Member

    Joined:
    Dec 9, 2016
    Messages:
    442
    Likes Received:
    1,576
    Can you bring a audible example of what you exactly mean? Engine sounds in TS and TSW are always looping sounds. There is no other way to do that yet. Often those loops are quite short (because there is nothing else available) and therefor some kind of audible for sure. Alternative is to have no engine sound or no loco at all in the game...
     
    • Like Like x 1
  6. CK95

    CK95 Well-Known Member

    Joined:
    Apr 13, 2019
    Messages:
    1,180
    Likes Received:
    3,163
    Loops are obviously needed, but I think what OP is trying to point out is how obvious the loops are, they definitely need mixing a little better on some of the TSW preserved units, the TRAXX locos being at the top of that list.
     
  7. Maik Goltz

    Maik Goltz Well-Known Member

    Joined:
    Dec 9, 2016
    Messages:
    442
    Likes Received:
    1,576
    Right, that is a common problem since TSs are alive. Often there is simply not a option to make it better. I'm doing this stuff for over 10 years now and i know how hard it is to get any loop for lots of trains. Making them the best looped sound is mostly not possible. The only way to make a unloopable sound to a loop is to granulate it, what ends up in a very synthetic sound. It is doable with some, but with others not. If you have only a few seconds of recordings for a specific sound, that is what you have to live with, unfortunately.
     
  8. CK95

    CK95 Well-Known Member

    Joined:
    Apr 13, 2019
    Messages:
    1,180
    Likes Received:
    3,163
    I have no doubt as to the the finesse required, however these issues were not present across the units in TSW2020, as I understand it, work is underway to address the sound issues on the TRAXX locos in TSW2 currently anyway.
     
  9. Maik Goltz

    Maik Goltz Well-Known Member

    Joined:
    Dec 9, 2016
    Messages:
    442
    Likes Received:
    1,576
    But that i can't believe. I already made some of those sound fixes for the TRAXX and the 143 (not released yet). The used sounds are the same and relatively clean looped. So it may be a different problem that some people suffer from?
     
  10. CK95

    CK95 Well-Known Member

    Joined:
    Apr 13, 2019
    Messages:
    1,180
    Likes Received:
    3,163
    Yes what I’m saying is that the loops as they exist in the live game currently, are not clean, the TRAXX loop is glaringly obvious, there’s almost a full second between the loops, the issue isn’t the sound itself (although there is an argument to be made there, this isn’t really the topic here) but splicing on the audio file is very poor, every 5 seconds there is a very obvious stutter where the loop repeats.
     
    Last edited: Jun 5, 2021
    • Like Like x 1
  11. Thorman

    Thorman Member

    Joined:
    Oct 21, 2018
    Messages:
    72
    Likes Received:
    98
    On xbox one X I have sound problems nearly every time I play. The sound loops are in fact a noise repeated very quickly, stuttering if you see my meaning.
     
    Last edited: Jun 5, 2021
    • Like Like x 2
  12. CK95

    CK95 Well-Known Member

    Joined:
    Apr 13, 2019
    Messages:
    1,180
    Likes Received:
    3,163
    That particular issue is a known issue between unreal engine and the Xbox OS, Matt did mention on the Cathcart stream that there may be a workaround that they are testing, but yeah I very quickly stopped playing TSW on Xbox because of that issue.
     
  13. Alex Shelestov

    Alex Shelestov New Member

    Joined:
    Sep 10, 2018
    Messages:
    10
    Likes Received:
    4
    The same LOVE on PS4-PS5 consoles.
    And there is definitely just a bug, cause all games use loops. But look at them - they don’t have this problem. I mean all of these car, tank, ship and flight simulators.
     
  14. Maik Goltz

    Maik Goltz Well-Known Member

    Joined:
    Dec 9, 2016
    Messages:
    442
    Likes Received:
    1,576
    Because all of them are using expensive middleware to prevent the issues and have more possibilities for sounds. Nothing a TSW can afford at the moment unfortunately (i would love to use middleware for making sound for the trains, but it is not possible yet at all).
     

Share This Page