1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What Happened To Specific Freight Car Sounds In Csx:hh Since The Update?

Discussion in 'PC' started by RMNRWY, Aug 18, 2019.

  1. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    They are missing. Try out the AC4400CW in any timetable scenario. The freight car sounds are missing. It's like a silent train.The only thing you hear is the slack taken up in the couplers at startup and a very muted rail joint sound in the distance. All other previous immersive sounds, as the freight cars rolled down the tracks are missing. The sounds are present when using the other locomotives. Why are they missing with the AC4400CW? How come nobody else has noticed this? DTG created another bug with an update. Who knows how long it will take before they fix this.
     
  2. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36

    You can hear how silent the train is.

    AC4400CW N536 Coal Train 8:10 Newell to Brunswick

    Now this is a video of how it used to sound prior to the 2020 upgrade. Daniel said he couldn't replicate this. Well, maybe he wasn't trying this specific service and listening to the coal cars pass.


    This issue isn't locomotive specific like I originally thought. It is freight car specific. At this time is seems to only affect the intermodal well cars, coal cars and autoracks.
     
    Last edited: Aug 21, 2019
    • Useful Useful x 2
    • Upvote Upvote x 1
  3. LeadCatcher

    LeadCatcher Well-Known Member

    Joined:
    Dec 9, 2016
    Messages:
    438
    Likes Received:
    709
    I have noticed this silence as well but have not completed as an extensive investigation. I would suggest putting in a bug report via official channels, but have seen a few report back responses stating it was a problem on the users side. Maybe if we get enough people commenting in the forums about the problem AND submitting bug reports, we can move past the update drivers or it’s your CPU and lower settings standard response.
     
  4. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Yea, I spent several hours yesterday fooling around with this issue. I extracted the current game and previous build versions that worked. Swapped files and it didn't solve the problem. Older manifests no longer fix the issue, as the core game was updated on Steam with the new 2020 interface. I do have an older build that I had saved and it still works. I just wish I had backed up my game on August 14th. In the patch notes, they mention some audio fixes. Since, the freight car sounds are present with the trash train in the NEC route, and with covered hoppers, oil tank cars, boxcars and coil cars in Sandpatch, I feel there must have been some code change that wasn't applied to the autoracks, intermodal, and coal cars in this update.
     
    • Useful Useful x 1
  5. nne4229

    nne4229 Well-Known Member

    Joined:
    Feb 26, 2018
    Messages:
    281
    Likes Received:
    269
    Matt? Dimitri?
     
  6. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Come on guys, help me out. Submit a ticket (CoyoteMan, Leadcatcher, CallumB, etc)

    DTG Daniel is blaming my system, as here is his quote from the Steam forum.

    "With just one single report it's hard to determine a cause so if your facing the same issue submit a ticket as for the time being the only report we have is from a single user. Due to not being able to replicate the issue internally using the data provided all I can assume is that the system is at fault."

    And here is their ticket reply

    Hi Steve,

    Your DxDiag notes that you have an i5 4670k. This CPU even when overclocked only has 4 available threads.

    Whilst this is enough to meet the game's minimum listed requirements it's not able to meet the recommended specs and due to this certain features may not always work as intended and as they appear on other systems.

    RECOMMENDED:

      • OS: 64-bit Windows 7 Service Pack 1, Windows 8 / 8.1 or Windows 10
      • Processor: Intel Core i7-4790 @ 3.6 GHz or AMD Ryzen 7 1700 @ 3.8 GHz
    I have not been able to replicate your experience using the information provided when using a PC featuring a locked i7 4790 and sadly we have no CPU's available for me to test on that have fewer threads.

    Many games now require 6 or more threads to run well and you can find various threads about this online if you feel like my response is inaccurate as you seem to mistake single-core performance and multi-threaded performance in your response.

    At this time nobody else has submitted a ticket featuring the same issue.

    Due to this right now I can only assume it's due to a lack of CPU resources so if you know anyone having the same issue whilst having an i7 or higher threaded CPU please get them to submit a DxDiag and a video similar to your own so I can provide this information to the Dev Team.

    Kind Regards,

    Daniel
    Dovetail Games Customer Support




    No computer system issue would isolate those three freight cars and leave all the rest alone. I have a feeling that DTG have just accepted the rail clack and coupler slack sounds as proof that everything is ok.

    Hey DTG Daniel, why don't you run the AC4400CW N536 Coal Train 8:10 Newell to Brunswick timetable service and post a video of the coal train as it goes by. Let me hear how it sounds. Prove to me that all the sounds are present with the coal cars as they pass. (wheel squeal, rumble, etc)
     
    Last edited: Aug 22, 2019
  7. nne4229

    nne4229 Well-Known Member

    Joined:
    Feb 26, 2018
    Messages:
    281
    Likes Received:
    269
    He is correct though, the when the cpu is over loaded one of the first things to get wonky is sounds. I’ve noticed this since day one. Since upgrading to a newer system 98% of the problems are gone.
     
    • Downvote Downvote x 1
    • Useful Useful x 1
  8. kalteVollmilch

    kalteVollmilch Active Member

    Joined:
    Jun 13, 2018
    Messages:
    105
    Likes Received:
    203
    Did you try the specific service he mentioned? I just tried this myself, using a i7 8650U (granted, mobile CPU and all that, but at least 8 threads), which was at 50-60% usage while running at about 3.4GHz. So, not overworked.
    But still I could reproduce the sound problems just as he described, the only thing that worked was the sound when the wagon wheels went over a switch
     
    • Useful Useful x 2
    • Upvote Upvote x 1
  9. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Thanks kalteVollmilch for trying the service and reproducing what I reported.
     
    • Upvote Upvote x 1
  10. Jeannot41

    Jeannot41 Active Member

    Joined:
    Jan 20, 2018
    Messages:
    174
    Likes Received:
    147
    I just performed this service and no sound when passing cars.
    I have an I7 7700 CPU - 3.6 Ghz
    16GB of ram
    Nvidia GTX 1060 3Gb
     
    • Upvote Upvote x 2
  11. TrainSim-Daniel

    TrainSim-Daniel Staff Member

    Joined:
    Sep 12, 2018
    Messages:
    191
    Likes Received:
    168
    Please ensure your all sending in DxDiags with your tickets after making sure everything is up to date.
     
    • Upvote Upvote x 1
    • Useful Useful x 1
  12. Dave Mel

    Dave Mel Active Member

    Joined:
    Aug 9, 2018
    Messages:
    395
    Likes Received:
    249
    this is not a PC problem it is also a PS4 problem as well. i dont know about xbox. since the new update to 2020 all audio has gone haywire. is is especially crap when engine sounds get to the top of the rev limit and sounds muffled, sometimes going silent. you can hear this when going into tunnels. ive heard this on the new caltrain and on NTP and wsr.. these are the only routes i have tried since the 2020 update
     
    • Upvote Upvote x 4
  13. rwaday

    rwaday Active Member

    Joined:
    Dec 12, 2016
    Messages:
    155
    Likes Received:
    54
    I have just started the scenario N536 an I have to admit that at first I thought that the sounds were not there. In order to hear them I needed to use a set of headphones and use the equalizer in the High Definition Audio program to boost those frequencies in order to hear them. Yes there is an issue.
     
    • Upvote Upvote x 2
  14. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Nice to see you are trying N536 with your I7 6700K. Did you watch both my videos to hear how most of the rumbling and wheel sounds are missing? Submit a ticket and this way they can't blame it on my I5 for this lack of sounds.
     
  15. rwaday

    rwaday Active Member

    Joined:
    Dec 12, 2016
    Messages:
    155
    Likes Received:
    54
    Ticket submitted. It seems that they will not accept anecdotal evidence but only a submitted ticket for some things
     
  16. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    MAJOR BREAKTHROUGH!!

    I fixed it. I replaced the BiLevelAutorack folder from the May 21, 2019 build and the sounds are back!!!!! The autorack cars were missing the sounds too. Now DTG just needs to acknowledge this error and update the game for the general public. It took me a lot of time to solve this issue. I unpacked and repacked the game at least 40 times. Adding and removing files and folders from previous builds. Now I will do it with the remaining folders involving the coal and intermodal well cars. Also, double checking to see if the core Audio SFX folder is responsible.

    UPDATE: I just replaced the other two folders and the coal car sounds are also working!

    Maybe DTG should hire me as a tester. ;)
     
    Last edited: Aug 23, 2019
    • Upvote Upvote x 7
  17. rwaday

    rwaday Active Member

    Joined:
    Dec 12, 2016
    Messages:
    155
    Likes Received:
    54
    This issue:
     
  18. Sunscreen

    Sunscreen Member

    Joined:
    Aug 16, 2019
    Messages:
    87
    Likes Received:
    75
    Impressive effort RMNRWY! Best of luck with the fix and I hope DTG can use it. Maybe ping them a reminder on Tuesday as its a bank holiday weekend in the UK this weekend.
     
    • Upvote Upvote x 1
  19. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Yep, that's it. Read my post up above as I just fixed the issue.
    I bet DTG heard the rail clack sound and assumed all was well. They just didn't realize all the other sounds were missing. (rumble, wheel squeal, etc)
     
    Last edited: Aug 23, 2019
  20. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Thanks, I'll get a ticket across to them with my discovery.
     
    • Upvote Upvote x 2
  21. mattbt667

    mattbt667 New Member

    Joined:
    Aug 23, 2019
    Messages:
    1
    Likes Received:
    0
    Ticket submitted as well. (Signed up here just to help get this resolved.) RMNRWY, nice work on your fix! Myself, I would have no idea how to apply those changes, so I will hope Dovetail comes through with an update and fix. :)
     
  22. nne4229

    nne4229 Well-Known Member

    Joined:
    Feb 26, 2018
    Messages:
    281
    Likes Received:
    269
    They'll blame hardware and never fix it. Lol
     
    • Downvote Downvote x 2
  23. hyperlord

    hyperlord Active Member

    Joined:
    May 20, 2019
    Messages:
    160
    Likes Received:
    77
    Steam loaded an Update today but I didn't find any changelog
     
  24. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Yea, I swapped a few folders from an older version and my Intel I5 turned into an I7 for free. :o
     
    • Upvote Upvote x 1
  25. LimitedEdiition

    LimitedEdiition Active Member

    Joined:
    Dec 16, 2017
    Messages:
    123
    Likes Received:
    236
    I don't trust them to release a patch anytime soon, so can someone upload the files somewhere in the meantime?
     
  26. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Here is a video I just took of the fixed sounds in TSW 2020. I picked an area where there is no rail joint or switch points, so you can hear the fixed missing sounds. I'm not sure why Bandicam stutters so much in the recorded file, as my in game play is smooth. This video file was low resolution so I could upload it quicker. The main thing is the sounds.


    Right now the fix involves extracting the main 14gb .pak file (TS2Prototype-WindowsNoEditor.pak) and replacing four folders from the May 21, 2019 build. I then have to repack it. So at the moment, there is no easy way to do it. I could always give the lengthy and time consuming process instructions, but let's hope DTG addresses this.
     
    Last edited: Aug 24, 2019
    • Upvote Upvote x 1
    • Useful Useful x 1
  27. nne4229

    nne4229 Well-Known Member

    Joined:
    Feb 26, 2018
    Messages:
    281
    Likes Received:
    269
    Someone get ahold of Matt please
     
    • Upvote Upvote x 1
  28. Trenomarcus

    Trenomarcus Member

    Joined:
    Dec 8, 2016
    Messages:
    46
    Likes Received:
    89
  29. Sunscreen

    Sunscreen Member

    Joined:
    Aug 16, 2019
    Messages:
    87
    Likes Received:
    75
    Perhaps Daniel should read this article, a short extract of which is pasted below which summarises the salient point ;)

    "Customer demand used to be about meeting inventory and service demands. Today, customer demand is about meeting and exceeding customers' expectations, in other words, their demand for customer service and experience. You must meet customers on their terms, when and where they want."

    Although I quite agree theres a good way and a bad way of making a 'customer demand'..
    https://www.forbes.com/sites/shephy...customer-service-on-their-terms/#6b38fb34caa2
     
    Last edited: Aug 25, 2019
  30. LastTrainToClarksville

    LastTrainToClarksville Well-Known Member

    Joined:
    Oct 12, 2017
    Messages:
    919
    Likes Received:
    682
    More likely as an unusually caring technician -- granted, with a single problem to resolve.
     
    • Upvote Upvote x 1
  31. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    Well, all is not well. I replaced the three folders to get this missing sounds back for the autoracks, intermodal well cars (GundersonHuskyStack) and coal cars. That works, but by doing that, the sounds go missing for freight cars in a maifest service. (boxcars, coil cars, covered hoppers, etc.) There is clearly something messed up with another file that is causing this strange issue since the August 15 2020 version update. Back to work.

    Summary

    After a bunch of testing, I concluded that
    the three freight cars that are missing 'specific' sounds such as wheel rumbling, flange squeal etc are; BilevelAutorack, CoalHopperBethogonII , and GundersonHuskyStack. They still have rail joint clack . I swapped out these folders and installed a previous version from way back on May, 21. I also, installed a previous version of the TS2Prototype\content\core\Audio folder. This restores the missing sounds for these three cars, but removes the same sounds from the remaining freight cars. Thus proving, that the update is responsible for this bug.

    So with the August 15, 2020 build 659, these are the freight car sounds that lost some of their sounds;

    BilevelAutorack, CoalHopperBethogonII , and GundersonHuskyStack.

    These are the freight cars that have their sounds working correctly;

    CSX_CoilCar, CSX50ftBoxCar, CSX5201ftCoveredHopper, CSXDOT117TankCar, NSC73CenterBeam

    UPDATE: Very close to having all the sounds working properly. Isolating the missing files .
     
    Last edited: Aug 27, 2019
    • Useful Useful x 2
  32. RMNRWY

    RMNRWY Member

    Joined:
    Mar 21, 2018
    Messages:
    26
    Likes Received:
    36
    I finally got all the sounds working correctly. It's actually just a few files responsible for the missing sounds. DTG has told me that they have had multiple reports and this issue should be resolved in a future update. Thanks to those who sent in support tickets.
     
    • Upvote Upvote x 2
  33. rwaday

    rwaday Active Member

    Joined:
    Dec 12, 2016
    Messages:
    155
    Likes Received:
    54
    Latest from DTG is that they are aware of the issue and a fix is being compiled for an upcoing update.
     
  34. nne4229

    nne4229 Well-Known Member

    Joined:
    Feb 26, 2018
    Messages:
    281
    Likes Received:
    269
    Upcoming when? Lol. Soon? (Tm)
     
  35. Anthony Pecoraro

    Anthony Pecoraro Well-Known Member

    Joined:
    Dec 11, 2016
    Messages:
    1,453
    Likes Received:
    1,553
    It’s out now.
     
  36. Steve Cummins

    Steve Cummins Member

    Joined:
    Dec 12, 2016
    Messages:
    33
    Likes Received:
    44
    Wagon sounds are still broken in CSX HH. I'm getting sound drop outs when passing another train.
     
  37. ARuscoe

    ARuscoe Well-Known Member

    Joined:
    Apr 9, 2018
    Messages:
    1,643
    Likes Received:
    882
    Submit a ticket for it. They might have thought it was fixed in the update, or it might be a new issue caused by the update...
     
    • Upvote Upvote x 1

Share This Page