All The "ugly" Visual Train Deformations I Am Experiencing In One Thread

Discussion in 'Train Sim World Discussion' started by grdaniel48, Nov 8, 2022.

  1. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    In order to inform, but also for DTG to have all the visual problems in just one place, about the strange issues with the trains since TSW3, on PS4.
    Please notice not all trains have these issues, but several ones.
    Even those visual problems does not happens all the time when driving them.
    Most happens, when driving on the route, not when stopped, and using the "zoom" visual mode for closer look.

    TSW3 - UGLY VISUALS 4.jpg TSW3 - UGLY VISUALS 3.jpg TSW3 - UGLY VISUALS 2.jpg TSW3 - UGLY VISUALS 1.jpg TSW3 - UGLY VISUALS 5.jpg
     
    Last edited: Nov 9, 2022
    • Like Like x 3
  2. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    TSW3 - UGLY VISUALS 10.jpg TSW3 - UGLY VISUALS 9.jpg TSW3 - UGLY VISUALS 8.jpg TSW3 - UGLY VISUALS 7.jpg TSW3 - UGLY VISUALS 6.jpg
     
    • Like Like x 1
  3. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
  4. Xander1986

    Xander1986 Active Member

    Joined:
    Mar 20, 2018
    Messages:
    238
    Likes Received:
    217
    That's the point off using a pc that's not follow the specs that's needed to run TSW3 or you have to power up youre graphics!
     
    • Like Like x 1
  5. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
  6. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
  7. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    TSW3 - UGLY VISUALS 29.jpg TSW3 - UGLY VISUALS 28.jpg TSW3 - UGLY VISUALS 27.jpg

    Here something strange about information about how to proceed:

    TSW3 - STRANGE INFORMATION.jpg

    At the top right, it is green light, it says it safe to proceed, but then "Restricted"!
    If it is restricted might be a yellow light, won't be?
    Any comment about it will be appreciated it.

    Finally to end with a nice detail, even it is not directly seen...

    TSW3 - BNSF TANK OIL INSIDE.jpg
    If you open the top hatch of a tank car, you can see the oil inside!
    Nice!
     
    Last edited: Nov 8, 2022
    • Like Like x 1
  8. rennekton#1349

    rennekton#1349 Well-Known Member

    Joined:
    Jun 5, 2022
    Messages:
    2,331
    Likes Received:
    1,171
    That's not the point and bad reasoning tbh. The next gen consoles can run triple A titles with good graphics and performance so it's more than enough to run tsw3. So these issues shouldn't be happening
     
  9. Xander1986

    Xander1986 Active Member

    Joined:
    Mar 20, 2018
    Messages:
    238
    Likes Received:
    217
    You're pc is way to old and doesn't work with this game. What you see is a result off the low settings.
     
    • Like Like x 1
  10. Xander1986

    Xander1986 Active Member

    Joined:
    Mar 20, 2018
    Messages:
    238
    Likes Received:
    217
    Please do not write bullsh*t! A PS5 have a quality like a Nvidia GTX3080 so that's not a good view off point.
     
  11. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    Well,... I am not using a PC. I am on PS4. So no much configuration possible.
    I clearly know this is not the best for TSW3.
    On TSW2 all trains looks really great!.


    But do not expect such big issues!
    Furthermore there is no performance issues about stutters or something like that.
    The change can not be so huge to cause such big visual deformations.
    Even considering no all trains suffer this, and not permanently.
    For example a BR187 headlights looks like triangles! Come 'on, this is not necesary!.
    The rest of that locomotive looks well, which is more "heavier" than the lights.

    DTG has mentioned it will improve memory resources and performance.
    Hopes that improves and eliminates these issues.
     
  12. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    There are 2 issues not related to performance:

    - The 2 cars together, is an issue we have seen on TSW2 too, but I noticed is happening more on TSW3.

    - About the hoppers, what I am showing is 2 of them have snow, but the last one, nothing!
     
  13. Xander1986

    Xander1986 Active Member

    Joined:
    Mar 20, 2018
    Messages:
    238
    Likes Received:
    217
    May i ask you how much FPS do you have with this settings? Let me explain... 30/40 FPS is engouh to have good game play. So if you have 60 fps power youre settings a bit.

    And when not reinstall your game complete. You have not the best console but settings like this is absolute not okay.
     
    Last edited: Nov 8, 2022
  14. rennekton#1349

    rennekton#1349 Well-Known Member

    Joined:
    Jun 5, 2022
    Messages:
    2,331
    Likes Received:
    1,171
    Not being mean or trying to start a fight. I was trying to point out that telling people to go buy a pc cuz of poor graphics on a console is not really the answer. Not everyone can afford a pc and consoles perform well for cheaper. And like how the op replied to your post, this was not an issue before.
     
  15. Xander1986

    Xander1986 Active Member

    Joined:
    Mar 20, 2018
    Messages:
    238
    Likes Received:
    217
    The reason why I'm writing that was that i had written already that the settings the problem is and this guy denies my whole answer.
     
  16. pveezy

    pveezy Well-Known Member

    Joined:
    Dec 18, 2021
    Messages:
    330
    Likes Received:
    508
    I recently submitted a ticket over some weird pop in I’m seeing on TSW3 (including TSW2 routes) that I didn’t see before even in the same route on TSW2. I summed up common scenarios:

    1. Missing freight cars. AI or player trains, external camera, the train will have gaps in it caused by some freight cars not appearing so it looks like 2 separate formations. But if you zoom camera closer suddenly the missing cars will pop in and the train completes. Seems most common right when you spawn into a yard but I sometimes see it on stationary trains. One that does it commonly is the cement train parked outside St Pancras often has cars popping into place as I’m passing it.

    2. “Skeleton” trains where some cars (mainly in EMUs) don’t have the exterior shell. So it’s basically a floor and seats rolling down the tracks until it gets close to you and suddenly the exterior shell pops into place.

    3. Missing loco. So a train will be approaching you that’s just coaches and then at the last minute a loco pops into place.

    4. “Hollow locomotive” where a loco exterior is there but it looks see through/hollow with no interior until you get close to it.

    TSW has always had scenery pop in but usually it’s farther ahead. These issues are happening when the train is pretty close to you. Also they seem pretty random. When/how they happen.

    Im trying to document them but here is an example of what I called “skeleton train” where one of the cars is just floor and seats. Also the cab is showing the “hollow train” problem.

    194E7F0B-5C89-4BB0-AEC8-F2C55E1EBF6C.jpeg

    I’m on PS5.

    These are glitches in the game and nothing to do with graphics settings. TSW2 routes for example are supposed to be running exactly the same so they shouldn’t have pop in on TSW3 that wasn’t there on 2.
     
    Last edited: Nov 8, 2022
    • Like Like x 1
  17. Xander1986

    Xander1986 Active Member

    Joined:
    Mar 20, 2018
    Messages:
    238
    Likes Received:
    217
    My advice is to reinstall the game complete from scratch. This behaviour is absolutely not correct.
     
  18. BLRy

    BLRy Well-Known Member

    Joined:
    Mar 14, 2020
    Messages:
    507
    Likes Received:
    319
    Can't remember how I did this but was quite unexpected...

    4e74da9c-8f1d-4b0b-addf-2bbd39c2e028.jpg

    Clinchfield on Xbox w/ TSW3
     
  19. stujoy

    stujoy Well-Known Member

    Joined:
    Aug 29, 2019
    Messages:
    5,546
    Likes Received:
    14,404
    There are no settings to play with on PS consoles. You assumed the OP had a PC that was low spec but that wasn’t the case, then after he explained he is on console you advise to alter the settings that don’t exist. Your advice is wrong and isn’t helping. Many of the issues in these pictures are happening on PS5 as well as PS4 as can be seen in the post above and as the game is released for PS4 the disfigured trains should not be happening on that console either.
     
    • Like Like x 9
  20. photonmonkey

    photonmonkey Well-Known Member

    Joined:
    Mar 17, 2021
    Messages:
    242
    Likes Received:
    299
    I reported a similar issue ages ago with the Rapid Transit Talent 2 and that was in TSW2 (still not fixed and the same in TSW3), but I agree there seem to be a lot more issues with LOD on TSW3 with various trains. Definitely not right even on a lowly PS4 which is what I am running on.
     
    • Like Like x 1
  21. antony.henley

    antony.henley Well-Known Member

    Joined:
    Jul 6, 2019
    Messages:
    1,544
    Likes Received:
    2,540
    Items 1 -4
    These has been happening since day one on the release of TSW 3 on the PS4 and I see it on the PS5 and I have also experienced it on the Series S and X. It is a TSW error and not console, not sure about a PC that's the dog's danglies.
    I have sent DTG Matt this from when I streamed on the release and I remember he said he was going to have a word with the engineers as it seems its a streaming issue within UE4.

    As per grdaniel48 posts alot of them are to do because he is using a PS4 as its a on Gen 8. Its unfortunate graphical glitches. TSW 3 works on GEN 8 but does not produce the best results like a PS5 or Series X

    Ten minutes into my release stream on the day of launch I was looking around the training center and saw the following:-



    Although I say in the stream im on the PS5 version of TSW 3 in fact I am using the PS4 version (unknown to me at the time) on the PS5.

    grdaniel48 if you can edit your first post and say that its a PS4 (pro?) then it would help people coming in for the first time reading.

    Cheers
    Hentis
     
  22. chieflongshin

    chieflongshin Well-Known Member

    Joined:
    Jan 4, 2019
    Messages:
    3,871
    Likes Received:
    5,779
    What the devil In egg fried rice is happening in that first post?
     
    • Like Like x 2
  23. photonmonkey

    photonmonkey Well-Known Member

    Joined:
    Mar 17, 2021
    Messages:
    242
    Likes Received:
    299
    I don't think some of this is due to the PS4 power limitations as some locos/MU's seem fine, For instance the Talent 2 on Rapid Transit is a triangulated mess when viewed from more than a couple of feet in TSW2 and TSW3 on PS4 but the Talent 2 on other routes such as nahverkehr dresden is perfectly fine at all distances.
     
    Last edited: Nov 9, 2022
    • Like Like x 2
  24. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    Thank you very much for your comments!
    Due to, they are mostly the same I showed on my images.
    But you have PS5 instead!

    So clearly, as I mentioned to have PS4, this is not the reason for having such weird visuals!
    As it happens on new gen consoles too.
    It is something related to the game.

    Again the change from TSW2 - where everything was displayed perfectly (event after all objects improvement) - to TSW3, which have some new features, can not cause those effects.
    For example as you can see I have no picture about Cajon Pass or SEHS.
    None of those effects happens there.
    With the only exception of the missing freight cars in the middle of the freight trains in Cajon, or even Sherman Hill too..
    Which you can fixed, if you "fly" with the camera near them, causing its suddenly appears.

    So as I mentioned at the end, DTG might improve performance and memory issues - which seems is causing that visual problems- , as they have also mentioned on the last Roadmap, they are working on.
     
    Last edited: Nov 9, 2022
  25. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    Yes, you are right!.
    I have reported that too on TSW2! last year.
    The front end at closer position, looks deformed!. Mainly the headlights
    Curiously that happened only on the RT Talent. Not on the KA one.
     
    Last edited: Nov 9, 2022
    • Like Like x 1
  26. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    Please also notice, I was thinking on buying PS5, but when I saw it has DLC quantity limitations - I have lot of them - it makes me change my mind.
    Furthermore information you have provided now, PS5 users are experiencing similar issues I have reported here - which I thanks a lot! - is another issue, about not to change to new gen console.
    Of course until those issues be fixed.
     
  27. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893
    Did it!
    Thanks for the advice.
    I am on standard PS4 not Pro one.
     
  28. photonmonkey

    photonmonkey Well-Known Member

    Joined:
    Mar 17, 2021
    Messages:
    242
    Likes Received:
    299
    Also on the DB 187 which is again a triangulated mess on PS4, if you exit the cab and move away a few feet the cab door renders as closed and then as you approach again it renders as open, very strange and clearly not what was intended.
     
  29. DTG Alex

    DTG Alex Community Manager Staff Member

    Joined:
    Jun 16, 2022
    Messages:
    389
    Likes Received:
    2,994
    Hello, jumping on the thread to share some insight into what most of the issues above actually are:

    Images of the trains looking "ugly" and broken is actually a purposeful feature in all modern games - let me explain why.
    All models in a game will have multiple versions of quality, for example, a simple structure would be:

    - A higher quality with all the detail (This is the model which ideally the player will see at all times)
    - A medium quality model
    - A low quality model

    This quality affects not only the shape of the model but also the texturing and colours you see on it.

    The way games use these different qualities is to help performance. Games will seamlessly swap models between the quality levels based on how large they appear on your screen, which typically refers to how far away they are. So for TSW's case, trains that you are either standing inside or next to should be on the highest quality, because they are right in front of you and we want to showcase the details. However, trains at a medium and then far distance away will drop down to a medium and then low quality - the reason being that you can't actually see most of these details anyway, so to help the performance of the game we lower the quality of objects further away.

    The end result should mean that you never actually notice the quality difference, and most players won't unless they really look for it. If you want to know more about this, search about "LODs" in games! It is vital to making sure we can run a game that has multiple high quality objects. This is also where the quality settings in your settings menu will affect your game, they (amoung countless other things) will also alter these distances the quality levels change at, all to help performance :)

    How does this relate to you issue? Well it could be that you're zooming into to distant models that are on their lower quality level, and so you're seeing the issues - or that you game itself isn't swapping the trains up to the higher qualities when they get closer to you (the player) and therefore you can see the low quality models up close - which wouldn't be intended.

    Eitherway, I hope this helps anyone interested understand more about it - if you are experiencing these lower quality models from right up close, it may be worth submitting a support ticket or checking your system.
     
  30. photonmonkey

    photonmonkey Well-Known Member

    Joined:
    Mar 17, 2021
    Messages:
    242
    Likes Received:
    299
    DTG Alex Thanks for this, yes I appreciate how LOD is used in games but I do think it needs to be looked at especially on the PS4, the issues with the DB 187 for instance where the cab door renders as open when you are right next to the loco but as you walk away it then renders as closed which is clearly not correct.
     
    • Helpful Helpful x 1
  31. Richard CZE

    Richard CZE Well-Known Member

    Joined:
    Aug 20, 2020
    Messages:
    480
    Likes Received:
    503
    Have you tried changing the HDMI cable? For HDMI 2.0 cable.
     
  32. Princess Entrapta

    Princess Entrapta Well-Known Member

    Joined:
    Jul 23, 2021
    Messages:
    1,503
    Likes Received:
    1,451
    That would not alter what the hardware is rendering. The LOD would remain low irrespective of the FPS limit the cable can handle at each supported resolution.
     
    Last edited: Nov 10, 2022
    • Like Like x 1
  33. Princess Entrapta

    Princess Entrapta Well-Known Member

    Joined:
    Jul 23, 2021
    Messages:
    1,503
    Likes Received:
    1,451
    I think in some of these screenshots it is quite clearly the latter.
    This train is right outside the cab window.

    The coaches with no walls and roofs are very much a constant presence in TSW3 at least on Series X/S though, part of why I still play TSW2. Something just isn't rendering them right.
     
    • Like Like x 1
    • Helpful Helpful x 1
  34. chieflongshin

    chieflongshin Well-Known Member

    Joined:
    Jan 4, 2019
    Messages:
    3,871
    Likes Received:
    5,779
    I'm not sure on how zooming in will impact this. i've never seen in 5 years of this game anything that bad under zoom. In my non technical opinion its not loading the high res models in time.
     
    • Like Like x 2
    • Helpful Helpful x 1
  35. Railmaster

    Railmaster Well-Known Member

    Joined:
    Feb 13, 2020
    Messages:
    320
    Likes Received:
    267
    I'm also on PS4 and have these errors especially since TSW3. But it occurs rather sporadically and not to the same extent as seen here! That's frightening!

    I'm also a lot in the outside view and usually it is good with zooming in. Except for the static error in Rapid Transit, where it gets angular when you zoom in.

    But what I have to see here is more than bad! That is not how it works!
     
  36. chieflongshin

    chieflongshin Well-Known Member

    Joined:
    Jan 4, 2019
    Messages:
    3,871
    Likes Received:
    5,779
    I just don’t seem the zoom thing being valid. Why would you release a product that goes from something acceptable looking to something not too dissimilar to a 4 year olds play dough train model under zoom.

    This effectively says you can enjoy tsw like this……
    upload_2022-11-10_18-15-46.jpeg

    However if you want to zoom in you get this….

    618F4204-473C-47B1-B768-4CF4F9D6930B.jpeg

    I’m really not sold. Based on what Alex said which is right this must be a random LOD loading glitch, error, bug, lag, whatever you want to call it.

    IT IS a tsw3 thing I think because I have stood next to stations on east coastway where walls have been low res even when standing beside them.

    I have seen this too on cajon pass and shared evidence where loco numbers have been blurry 20m away and not snapped into the same res as train until probably 5m away. It’s not PS4 specific I’m afraid.
     
    Last edited: Nov 10, 2022
    • Like Like x 3
  37. fabienlimp95

    fabienlimp95 Active Member

    Joined:
    Jun 6, 2019
    Messages:
    156
    Likes Received:
    176
    Sorry but this problem was actually discussed and showcased in several threats, so it isnt just a problem for some players but a omnipresent one for a majority of us.

    Simply pointing out to submit a ticket isn't going to do it. The Developers should be aware of this and acknowledging this problem open to the community and start working on a fix. Its not game breaking stuff mostly but a big big immersion braker. And its superbly annoying.

    Looking forward to hear from the team about this issue and possibilities to solve it.
     
    • Helpful Helpful x 2
  38. grdaniel48

    grdaniel48 Well-Known Member

    Joined:
    May 20, 2020
    Messages:
    1,316
    Likes Received:
    1,893

    Thanks DTG Alex for your comments about it.
    Yes I am aware about that "technology" about the quality visuals of the objects.
    Which has sense.
    But clearly this is not the case.

    First of all, never happened on TSW2 - whit the only exception of the RT Talent 2, I had reported last year.
    Second, that technology is used mainly for secondary objects - I mean not the train - which are far away, like the tracks, trees, etc.
    But this is happening with the train which is not so far away too. It only happens when you use the "zoom view mode" (sorry I do not remember the exact name now), which from a relative short distance you zoom it, in order to see the train closer.

    Please notice I have been using that feature since a long time ago , first on TSW, then TSW2, but also TSW3 as - I have mentioned. - those ugly visuals does NOT happens on all trains. Just on some of them. Even on TSW3.
    Even partially. For example the BR 187, which the rest of the locomotive it is showed Ok, but one of the most visible parts, like the lights when turned on, are changed from round ones, to triangles!

    As to the door which appears closed even if it was open - mentioned by other member above - it is an issue of that locomotive only, which I also reported on a thread last year.

    Again one of the curious facts about this issue, is that when you are with your train stopped at a big terminal - for example the ICE 1, with several other heavy - from the performance point of view- trains around like ICE3, DB 101 + IC coaches, and Dostos, etc on an area surrounded by big buildings, and lot of other objects, - so really heavy for the resources, but you zoom it, and there is no visual deformation, and all details are ok!

    So then frankly speaking, here is happening something different!.
    Furthermore considering as mentioned, this not happens with all trains.
    For example the US freight locomotives, the Javelin, Class 375, 465, ICE 3, 612, Red Talent, Class 66, DB 155, etc.

    Not forget to mention, PS5 users are suffering too!

    I believe you have to check / improve the "zoom visual mode" how affects the visual models of some of the trains.

    I want to special mention again, this thread was created in order to show what I was "suffering" about visual issues with TSW3.
    My idea is DTG be aware about it, and try to find a solution for all members with this issues..
    Mainly considering this was not caused for being a previous gen console, as new ones are also experiencing this.
    Please kindly understand, Thank you.
     
    Last edited: Nov 10, 2022
    • Helpful Helpful x 2
    • Like Like x 1
  39. cloudyskies21

    cloudyskies21 Well-Known Member

    Joined:
    May 9, 2021
    Messages:
    707
    Likes Received:
    1,671
    Just to add, I'm also experiencing a lot of these issues on Xbox Series X. Most frustratingly, I've been playing Dresden Chemnitz recently and I'm seeing a lot of AI trains that don't fully pop into view (as someone mentioned above, skeleton trains where you see the seats but no exterior shell etc - just to clarify, this is seen from a standard cab view with no zoom). This really spoils the immersion on TSW. :|
     
  40. Princess Entrapta

    Princess Entrapta Well-Known Member

    Joined:
    Jul 23, 2021
    Messages:
    1,503
    Likes Received:
    1,451
    I think based on the abundance of experiences it's pretty clear that there's something not quite working right in TSW3 when it comes to correctly loading the higher LOD versions of things when they get within a certain range of the player's locomotive. It may be related to the ubiquitous problem of many parts of any given consist not rendering at all, or only rendering certain elements like seats. It may be another glitch independent of that.

    It's not a problem in TSW2, so it's perhaps something to do with optimisations made to make the process more efficient in TSW3? Or something that was changed in how TSW3 handles LOD popin? I know there have been other issues with scenery LOD in the middle distance popping back and forth from high res, to low res, and back to high res.
     
  41. pveezy

    pveezy Well-Known Member

    Joined:
    Dec 18, 2021
    Messages:
    330
    Likes Received:
    508
    Here’s a couple examples of the weird graphics glitches I see pretty regularly, this is on PS5.

    Video 1:
    Approaching the station you can see a stopped Talent 2. As I zoom closer with external cam you can see the exterior shell of most of the cars has rendered but for some reason the middle one is missing and doesn’t “pop in” until I move the camera close. It doesn’t seem like a general LOD issue because it only effects one car, not the entire train:


    Video 2:
    Walking up to 2 locos parked outside Dresden Hbf. You see that the locos themselves render but their interior is missing, so they are “hollow”. It’s not until I walk up very close to them that their interiors “pop in”. I see that issue on foot, free cam, or when I’m driving myself and approaching an AI train (but only happens sometimes):



    And keep in mind this is a TSW2 route but I never saw these issues playing it on TSW2.
     
    Last edited: Nov 11, 2022
  42. FredElliott

    FredElliott Active Member

    Joined:
    Feb 12, 2022
    Messages:
    159
    Likes Received:
    127
    You already posted this issue in September and solved your own issue https://forums.dovetailgames.com/th...ke-kassel-–-würzburg-route.58826/#post-537825

    From your testing, install TSW3 and all your addons on the internal drive

    If its still occurring then your drive is old and probably on its way out if its an OG PS4. If its not then flatten the PS4 and reinstall the OS + games from scratch to eliminate fragging

    The problem is simply that your drive cannot stream the LOD models fast enough, and if other people with PS4s are not seeing the LOD issue then your drive is the issue
     
  43. FredElliott

    FredElliott Active Member

    Joined:
    Feb 12, 2022
    Messages:
    159
    Likes Received:
    127
    Seperate issue to the OP's problem. His issue is seeing low detail LOD at near distance, not the carriages/interiors missing issue
     
  44. Stephen Crofts

    Stephen Crofts Well-Known Member

    Joined:
    Aug 24, 2020
    Messages:
    852
    Likes Received:
    871
    DTG Alex
    It really isn’t a LOD issue happening. It’s a new break of created liveries caused by the last update. here I am stood right next to the model with what was a perfectly working livery last week.
    1857093C-06AE-4439-B82B-1663C68D667B.jpeg 72A27FB1-FD7A-41C0-AE41-1B90266D6CD9.jpeg CB3690BD-7D95-43CD-B341-F34ACC25741F.jpeg E1597FC3-E07A-46B9-AC67-276F916D0F0D.jpeg

    Apart from the livery issue, with the LOD it does seem that TSW3 has the lower quality models appear much closer to the player than before. It’s very very noticeable both with train models and line side scenery. sos is where I first started noticing that trend- the houses look awful- but with tsw3 it just seems LOD distance is much less than I remember before.
     
  45. chieflongshin

    chieflongshin Well-Known Member

    Joined:
    Jan 4, 2019
    Messages:
    3,871
    Likes Received:
    5,779
    Just to jump in back of post above, I don't really use liveries but I am still seeing these issues on the normal base liveries
     
    • Like Like x 1
  46. DTG Alex

    DTG Alex Community Manager Staff Member

    Joined:
    Jun 16, 2022
    Messages:
    389
    Likes Received:
    2,994
    This issue is a separate problem unrelating to the Lods before - the team are aware and are trying to implement a solution.
     
    • Like Like x 2
  47. stujoy

    stujoy Well-Known Member

    Joined:
    Aug 29, 2019
    Messages:
    5,546
    Likes Received:
    14,404
    I’m seeing that the issue of trains not loading at all until at a close distance and the interiors showing but not the outsides even on gen 9 consoles is being ignored in terms of replies and comment from DTG on the forum.

    I don’t see the automatically created LODs with the wobbly shapes that often on PS5 because most things are well in the distance before those happen but it was always a bit of an issue on PS4 but there are exceptions like some house models on SoS. There appears to be more use of the automatic LOD creation now than before as older house models and building scenery on the same route don’t disfigure in the same way on SoS or other routes, unless the distance at which the wobbly shapes appear is much less than before and much less than it should be on those assets. There may need to be one more manually created LOD before the disfigurement happens on scenery that relies on parallel lines staying parallel if that is the case.
     
    • Like Like x 2
  48. Princess Entrapta

    Princess Entrapta Well-Known Member

    Joined:
    Jul 23, 2021
    Messages:
    1,503
    Likes Received:
    1,451
    As I said, there are a few issues with rendering unique to TSW3, but they have in common that they are in TSW3 but not TSW2, and that in the case of at least two of them, they are LOD issues (the low LOD models not updating as they get close to the player's train, and the issue of trees switching from high to low LOD and back again)

    What's clear is TSW3 is doing something differently to TSW2 when it comes to loading models and textures, which is bugging out in a variety of ways that it does not do in TSW2, leading on the one hand to these LOD issues and likely also in a different manner to the issues of parts of a consist not rendering at all, since it's unlikely to be completely unrelated. There's a good possibility that the invisible stuff simply failed to load at an earlier step where it would have loaded the low LOD version, while the low LOD trains are ones which managed to load in but then failed at the step of loading the high quality assets.
     
    • Like Like x 1
  49. bljohansson#4171

    bljohansson#4171 Member

    Joined:
    Mar 25, 2022
    Messages:
    59
    Likes Received:
    28
    This so much. It's probably the most glaring issue with TSW3. And as people have been saying over and over, it affects both TSW3 compatible routes and TSW3 native routes. I'm on XSX and I saw it on HRR as recently as today.
     
    • Like Like x 1
  50. pveezy

    pveezy Well-Known Member

    Joined:
    Dec 18, 2021
    Messages:
    330
    Likes Received:
    508
    Had a weird one happen on PS5 yesterday… in about 100 hours of gameplay it’s the first time that it happened.

    Running the Dresden-Reisa 146 on Dresden-Reisa toward the end of the route my cab seemed to switch to “low res” mode or something… you can see all the symbols near the switches etc are blurred and overall the dashboard looks lower quality than it should. Screens look normal. It stayed like this for the entire end of the run. I tried switching to external camera and moving far away, then switching back to internal cam to “reset” it but it just stayed in this low quality look. Later on I ended the service and tried a new one with the same loco and it went back to looking high quality.

    FA56F53E-9093-4344-A399-E10E717DAD74.jpeg

    (brightened the screenshot to make the issue more obvious)
     

Share This Page