PC East Coastway: Several Bugs (after September 29th Update)

Discussion in 'Technical Reports' started by cwf.green, Sep 29, 2020.

  1. cwf.green

    cwf.green Well-Known Member

    Joined:
    Mar 4, 2019
    Messages:
    460
    Likes Received:
    651
    1. The HUD AWS/warning light seems reversed. When the AWS flower is lit up after starting the train or when passing the AWS magnet for a signal with cautionary aspect the HUD yellow light goes out, but when the signal is green it lights up yellow. I'm not 100% sure but the HUD light also seems to go out when the DSD alarm rings. So basically when there is a need for caution the goes out and when everything is clear it lights up. This is surely the opposite of what would be intuitive, no?

    2. I can report that the brake cylinder gauge is still broken. It always reads zero.

    3. The brake force is massively exaggerated. It was, to my knowledge, realistic in TSW2020. Right now a step 3 application from 90mph stops the train in around 22-23 seconds. According to real drivers it should be 36 seconds.

    4. This is more general but the cab motion is way too strong and unrealistic. When you notch up the throttle the camera jumps backwards as if someone kicked you in the torso :D, and when you brake (even in step 1) it is even worse. It behaves as if the camera was a small weight connected to a string from the roof of the cab. Basically there is no damping or stiffness in the camera connection to the seat. A real person has muscles/tissue and a spine that will dampen accelerations quite well, unless you are in a performance car or there is a sudden harsh bend in the tracks.

    Can anyone honestly say that the camera motion in the Class 377, right now, is realistic?
     
    • Like Like x 2
  2. FD1003

    FD1003 Well-Known Member

    Joined:
    May 10, 2019
    Messages:
    2,031
    Likes Received:
    2,988
    I've done some extremely basic testing on xbox and these are the results:
    It was the opposite for me, I activated AWS, then sat down put the reversed to forwars the ! was lit up and then I extingushed it correctly by pressing the AWS reset. Same for the DRA.

    It worked fine, I tried to do everything, open/close doors applying power while the brakes were still on etc... but did not manage to break the brake cylinder gauge. Working correctly.

    Sadly this is happening here as well, I'd honestly prefer if they gave us back the TSW1 physics without the adhesion feature, having learnt all the braking points it feels wrong to drive the 377 in this state... almost like controlling a model train. Step 3 is ridicoulosuly strong.

    Same on xbox for point n.4 as well, but honestly I hope they tweak the 377 performance a bit
     
    Last edited: Sep 29, 2020
  3. cwf.green

    cwf.green Well-Known Member

    Joined:
    Mar 4, 2019
    Messages:
    460
    Likes Received:
    651
    Weird, maybe it's bugged on PC but not on XBOX, or did you check on both?

    It is so weird, the physics was quite good (I think, real drivers can correct me) in TSW2020 for the Class 377, so I don't know why they changed it.

    I think that either the motion acceleration is too strong (no damping) or the change in acceleration for the Class 377 (the jerk or d^3x/dt^3) is too high. Too high jerk would basically be that the traction comes on too quickly, I know some EMUs and electric locomotives digitally control the rate of change for the tractive effort to be slower than what the motors can achieve. You can see this on the German locomotives in TSW2, but I don't want to speculate how this is in reality on the 377.

    Actually, now that I think of it, it has to be the camera acceleration. Just try to remember back to when you are sitting in a car and accelerating normally, you probably aren't knocked back in your seat. A normal cars acceleration is much higher than a trains.
     
  4. FD1003

    FD1003 Well-Known Member

    Joined:
    May 10, 2019
    Messages:
    2,031
    Likes Received:
    2,988
    Nope, only only on xbox... so I think chances are it's a pc only problem since I think it would be even stranger if only worked on xbox...

    Completely agree.

    Honestly I don't mind it that much... but yeah it's a bit overkill
     
  5. xavpin234

    xavpin234 Member

    Joined:
    Apr 29, 2017
    Messages:
    56
    Likes Received:
    51
    yup can comfirm both the brake gauge and aws reverse status are still present ON pc at least
     
  6. Rudolf

    Rudolf Well-Known Member

    Joined:
    Dec 9, 2016
    Messages:
    1,598
    Likes Received:
    2,049
    Confirm the AWS HUD issues are still there.
     
  7. fanta1682002

    fanta1682002 Well-Known Member

    Joined:
    Dec 22, 2019
    Messages:
    990
    Likes Received:
    459
    yes pc
    yes
     
  8. grumypop51

    grumypop51 New Member

    Joined:
    Jan 31, 2020
    Messages:
    26
    Likes Received:
    16
    Brake gauge still not working for me either. Did the update. Authenticated files and yet....................
    Also today had horn staying on in GP 38-2 Peninsula corridor. Never did that in TSW 202 for me. But the big issue is making sure the gauges all work correctly for those who like to drive without the HUD every now and then for the truly immersive experience.
     
  9. mclitke

    mclitke Well-Known Member

    Joined:
    Sep 1, 2020
    Messages:
    1,221
    Likes Received:
    2,727
    I read somewhere here that the patch has not actually applied on PC yet. The user found out that only support for the preserved collection has been downloaded, not the fixes themselves. Maybe we get that patch on PC today with the release of preserved collection?
     

Share This Page