Looks Like I'm Well And Truly Buggered !!!

Discussion in 'PC Editor Discussion' started by spikeyorks, Mar 26, 2024.

  1. spikeyorks

    spikeyorks Well-Known Member

    Joined:
    May 31, 2023
    Messages:
    768
    Likes Received:
    1,027
    I'm not quite sure what I have done but the reality of the situation is as follows.
    1) The Editor now crashes on Start-Up (at 70%).
    2) There is now nothing at all in my PlugIn / DLC folder (other than a few bits and pieces).

    I attempted an un-install (which is where I probably 'lost' my DLC) and now don't know the best way forward.
    Delete absolutely everything to do with EPIC and then start again.....but what's the best way of doing that?
    Or is there anything I can do now to link up my Editor files with my current game (despite being unable to actually open the Editor itself)?

    Welcome to hear some suggestions........so long as you don't laugh too much :)
    (By the way I am technically illiterate so, if you do have some practical suggestions please spell them out slowly). Thanks.

    Now back to Scenario and Livery Editors for the time being.
     
  2. pwilson79

    pwilson79 Active Member

    Joined:
    Apr 18, 2021
    Messages:
    168
    Likes Received:
    223
    Not sure how I would begin to solve that, to be honest. As far as launching the editor goes, I'm sure you would have thought about this, but have you tried launching the game itself (TSW4) and closing it after it loads the menu? I know it's not quite the same problem as we see after an update to the game, but I guess it couldn't hurt?
     
  3. jackthom

    jackthom Active Member

    Joined:
    Aug 22, 2020
    Messages:
    311
    Likes Received:
    160
    I’m not near my PC at the moment to check but does the Epic Launcher give you any option to update or reinstall the editor?
     
  4. RobertSchulz

    RobertSchulz Well-Known Member

    Joined:
    Oct 10, 2023
    Messages:
    1,478
    Likes Received:
    2,056
    It only gives you the option to verify the files (getting to the window by clicking on "Manage") or uninstall it. I tried it once but it kind of didn't succeed. My perception is that the capabilities of the same feature on Steam are far better than the ones Epic Games does offer.

    Screenshot (10285).png
    Screenshot (10287).png
     
    Last edited: Mar 27, 2024
    • Like Like x 1
  5. spikeyorks

    spikeyorks Well-Known Member

    Joined:
    May 31, 2023
    Messages:
    768
    Likes Received:
    1,027
    Right guys. Thanks very much for your input. I have now managed to fix my system (at the cost of losing a little bit of DLC but that isn't the end of the world) and have also learned a bit in the process. So I will share that here now.

    1) My problem turned out to caused by my use of God-Mode. Someone pointed me in the direction of mods in general so I stripped everything out of the main game and, bingo, the Editor loaded first time.
    2) Prior to this I had done a few uninstalls / reinstalls. As has been pointed out above you can do this with Epic Launcher however, in my case, I had no idea where Epic launcher was. In the end I found it on my system from the Start button and added it to my toolbar. In Epic Launcher I can then go into my Library where the uninstall / launch buttons are located.
    3) So I uninstalled TSW4 Editor. Removed all my mods from TSW4. Then re-installed the Editor using Epic Launcher as in (2).
    4) I then opened TSW4 (now a vanilla version with no mods) before then opening my 'new' Editor to link it. (It opened first time).
    5) I then put all my mods back into TSW4. Opened the game, opened the Editor and the editor crashed again. (So I knew it was a mod).
    6) By a process of elimination I then worked out it was God-Mode. (Put it in and the editor crashed, take it out and it loaded).
    7) Finally I realised that I was trying to put back in an earlier version of God-Mode (v0.5.2) when I needed v0.5.4 at least for GOBLIN.
    8) In the end I actually installed the really current version of God-Mode (v0.5.5) and everything worked OK.

    I hope that this little window in to my last 24 hours is helpful to anyone, like me, who hasn't got a clue what they are doing but still bumbles along with it anyway. Thanks again to everyone who put forward suggestions to help me. We got there in the end. :D
     
    Last edited: Mar 28, 2024
    • Helpful Helpful x 3
    • Like Like x 1

Share This Page