1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Raildriver Support Now For Tsw

Discussion in 'Community Projects & Developer's Area' started by crrispy, Dec 27, 2019.

  1. crrispy

    crrispy New Member

    Joined:
    Dec 25, 2019
    Messages:
    9
    Likes Received:
    2
    Hi All,

    As you might have seen elsewhere (Steam TSW forum, UKTS...), I have started working on Raildriver support for TSW. It is based on keyboard emulation using PI Engineering MacroWorks 3 and its associated scripts (more or less 1 script for each loco because they all have some different controls and behaviours, with a small supplied program to switch manually between locos).
    The current version is always available @ https://www.railsim-fr.com/forum/index.php?/files/file/1682-train-sim-world-raildriver-interface/

    Currently supported in version 1.2: the locos of CSX Heavy Haul, Great Western Express, Main Spessart Bahn & Tees Valley. Next ones will be Northern Transpennine then Long Island Railroad.
    Please read carefully the readme file for instructions, limitations, etc... it's by no means perfect but already quite pleasant compared to keyboard/mouse only if you have a Raildriver.

    Feedback always welcome.
     
    • Like Like x 1
  2. StratPlayer62

    StratPlayer62 Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    317
    Likes Received:
    324
    I just tried this, however I've run into a problem. My MacroWorks 3 Launch file is located in

    C:\Program Files (x86)\PI Engineering\MacroWorks 3.1 for Raildriver

    And it looks like your program is expecting the file to be in

    C:\Program Files (x86)\PI Engineering\MacroWorks 3.1

    I have the folder MacroWorks 3.1 but nothing is in it, not sure why. I tried copying all of the contents of my folder MacroWorks 3.1 for Raildriver which contains the MacroWorks 3 Launch file, into the MacroWorks 3.1 folder, but it still isn't working.

    Any suggestions?

    Thanks
     
  3. crrispy

    crrispy New Member

    Joined:
    Dec 25, 2019
    Messages:
    9
    Likes Received:
    2
    Hi,
    It's because you have the MacroWorks for TS installed, not the generic one which the readme file points to. Best would probably to install both if you still use MacroWorks for TS, then they will each live in their own directory without interfering (of course only lauch one at a time).
    In Help -> about, must be 1.1.2.11.

    If you use CobraOne's program for TS, then you can completely remove MacroWorks for TS and only install the generic one.
     
  4. StratPlayer62

    StratPlayer62 Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    317
    Likes Received:
    324
    OK thanks, I didn't catch that.

    I'm not familiar with CobraOne's program. Is it different/better than MacroWorks program?
     
  5. StratPlayer62

    StratPlayer62 Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    317
    Likes Received:
    324
    Well I downloaded and installed the version, but for some reason it won't run. The program starts, then sends up an error message saying there was a problem and to check the log file, however I can't find a log file anywhere. Guess I will take this up with PI Engineering.
     
  6. crrispy

    crrispy New Member

    Joined:
    Dec 25, 2019
    Messages:
    9
    Likes Received:
    2
    The ErrorLog.txt is in C:\Users\(your user)\AppData\Local\PI Engineering\MacroWorks 3
     
  7. crrispy

    crrispy New Member

    Joined:
    Dec 25, 2019
    Messages:
    9
    Likes Received:
    2
    Hi all,

    Version 1.4 is online, with added support for Northern Transpennine locos & LIRR M7.
    Now time to play the game a little and refine settings if needed :)
     
    Last edited: Dec 28, 2019
  8. StratPlayer62

    StratPlayer62 Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    317
    Likes Received:
    324
    Thanks, right where you said it would be.
     
  9. crrispy

    crrispy New Member

    Joined:
    Dec 25, 2019
    Messages:
    9
    Likes Received:
    2
    So did you find the problem?
     
  10. StratPlayer62

    StratPlayer62 Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    317
    Likes Received:
    324
    I read over the log but didn't see anything obvious, I sent it to PI's tech support.
     
  11. crrispy

    crrispy New Member

    Joined:
    Dec 25, 2019
    Messages:
    9
    Likes Received:
    2
    Send me the log in pm, I'll see if I can understand what's going on.
     

Share This Page