1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stutters After Latest Updates.

Discussion in 'PC Discussion' started by Airbus A319, Oct 3, 2020.

  1. BinaryRun

    BinaryRun Active Member

    Joined:
    Oct 15, 2020
    Messages:
    149
    Likes Received:
    89
    Callum B.

    I just added your AA stuff and the texturestreaming. Removed staticmesh since I wanted it to do what texturestreaming does.

    Code:
    r.BloomQuality=3
    r.TextureStreaming=0
    r.ViewDistanceScale=10
    r.Shadow.DistanceScale=2.0
    foliage.LODDistanceScale=10
    r.TemporalAASharpness=1.0
    r.TemporalAASamples=64
    
     
  2. Callum B.

    Callum B. Well-Known Member

    Joined:
    Aug 9, 2018
    Messages:
    556
    Likes Received:
    926
    Let me know how you like the changes. :)
     
  3. tallboy7648

    tallboy7648 Well-Known Member

    Joined:
    Apr 9, 2020
    Messages:
    2,330
    Likes Received:
    2,373
    I get stutters on my xbox only on the Bakerloo Line which is odd
     
  4. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    1,312
    Likes Received:
    2,722
    Here's mine FWIW;

    [SystemSettings]
    r.ViewDistanceScale=2
    r.StaticMeshLODDistanceScale=0.60
    foliage.LODDistanceScale=5
    r.TextureStreaming=0
    r.Shadow.CSM.MaxCascades=10
    r.Shadow.DistanceScale=2.0
    r.ShadowQuality=5
    r.DefaultFeature.MotionBlur=0
    r.BloomQuality=1
    r.TemporalAASamples=64
    r.SkeletalMeshLODBias=-2
    r.Color.Mid=0.4
     
  5. BinaryRun

    BinaryRun Active Member

    Joined:
    Oct 15, 2020
    Messages:
    149
    Likes Received:
    89
    There definitely seems to be less stuttering. You know how when you load the game into a busy station, turn the for the first time camera and you get a moment of stutter? That is still there, but less.

    I also used to have that when switching to free cam (nr 3) and moving it for the first time after switching camera's etc, but those stutters seem to be gone or at least to a noticeable degree.
     
  6. TerryBalldriver

    TerryBalldriver Member

    Joined:
    Jan 12, 2019
    Messages:
    35
    Likes Received:
    26
    Are we going off topic here. DTG Natster has acknowledged this thread and DTG are looking into it. Surely we shouldn't be messing around with settings etc. It's a problem their end.
     
    • Like Like x 1
  7. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    1,312
    Likes Received:
    2,722
    It’s been a problem their end for 4 years. It ain’t going away anytime soon.
     
    • Like Like x 3
  8. BinaryRun

    BinaryRun Active Member

    Joined:
    Oct 15, 2020
    Messages:
    149
    Likes Received:
    89
    Does anyone else have a brief freeze on Class 166 / GWE? I have them in the following situations:

    1) After you stop at a station and the system switches from 'arrive at destination' to 'unlock doors' as your objective.
    2) The same, but the other way around. After you close the doors, when it switched from 'close doors' to 'your next station' as the objective.
     
  9. Callum B.

    Callum B. Well-Known Member

    Joined:
    Aug 9, 2018
    Messages:
    556
    Likes Received:
    926
    No, it is absolutely not off-topic to discuss suttering and how to mitigate it. Whether or not a user wants to mess with their settings is entirely their choice. Someone here asked for help, and I have helped them. Regardless of whether or not stuttering is a core problem that DTG needs to fix, it stands that the stuttering exists and users may want to try alternative solutions. After all, the original post says:
    So no, we are entirely on-topic here, thanks.
     
    • Like Like x 2
  10. bescot

    bescot Member

    Joined:
    Dec 14, 2016
    Messages:
    55
    Likes Received:
    68
    I am getting a periodic stutter in DX11, where the fps drops slightly, say 50 to 44 and there is an audible glitch, as in the motor or engine sound rises in pitch slightly then falls back to normal - especially noticable with the 377 and 165. Is this what others are seeing?
     
    • Like Like x 2
  11. bescot

    bescot Member

    Joined:
    Dec 14, 2016
    Messages:
    55
    Likes Received:
    68
    Absolutely, and did in TSW1 too. It coincided with the blip sound, which I removed with a mod. Even though there is no sound I still get that graphical stutter.
     
  12. tallboy7648

    tallboy7648 Well-Known Member

    Joined:
    Apr 9, 2020
    Messages:
    2,330
    Likes Received:
    2,373
    I get stutters on the Bakerloo line on my console so this is a problem that 2 months after release has yet to be resolved. I wouldn't say it's off topic
     
    • Like Like x 1
  13. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    1,312
    Likes Received:
    2,722
    You can see the sort of stutters/pauses I’m getting here. They’re not game breaking at all, but really do need ironing out imho...



    I’ve fiddled a bit with the settings since I recorded this and I’d say it’s maybe a bit better, but then that could be me just thinking it is. Essentially though this is 4K Ultra with 110% Screen Percentage running under DX12. My edited engine.ini is as follows (with the change being the StaticMeshLODDistanceScale going from 0.60 to 0.70)

    [SystemSettings]
    r.ViewDistanceScale=2
    r.StaticMeshLODDistanceScale=0.70
    foliage.LODDistanceScale=5
    r.TextureStreaming=0
    r.Shadow.CSM.MaxCascades=10
    r.Shadow.DistanceScale=2.0
    r.ShadowQuality=5
    r.DefaultFeature.MotionBlur=0
    r.BloomQuality=1
    r.TemporalAASamples=64
    r.SkeletalMeshLODBias=-2
    r.Color.Mid=0.4

    The stuttering is no different under DX11 with no engine.ini changes.
     
    Last edited: Nov 9, 2020
  14. londonmidland

    londonmidland Well-Known Member

    Joined:
    Nov 8, 2017
    Messages:
    1,350
    Likes Received:
    5,002
    The stuttering is caused by the tiles loading in and out I think. I think it needs to be done more efficiently, as it seems there's no difference to having in on an SSD as opposed to a HDD.
     
    • Like Like x 2
  15. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    1,312
    Likes Received:
    2,722
    It’s not, it’s something different. The ‘pauses’ I would say are tile loading (which can also be seen in that video, probably lasting 0.5-1.0 seconds) but the stutters are probably 0.1-0.2 seconds. They are way too frequent and seem to be unique to TSW2.

    For what it’s worth, I’ve no doubt (admittedly in TSW2020) that changing from an HDD to SSD made a big difference for me.
     
    Last edited: Nov 9, 2020
  16. BinaryRun

    BinaryRun Active Member

    Joined:
    Oct 15, 2020
    Messages:
    149
    Likes Received:
    89
    Can you please link me to that mod? I'd love to check it out. I always kinda dislike it that the game bleep tells me when the doors are closed, before the actual cab light does.
     
  17. Shaun123

    Shaun123 Well-Known Member

    Joined:
    Jan 22, 2018
    Messages:
    221
    Likes Received:
    414
    Yes, as you mentioned, I (and think most of us) get similar, minute stutters, but these are hardly game-breaking but they are noticeable!
     
    • Like Like x 2
  18. bescot

    bescot Member

    Joined:
    Dec 14, 2016
    Messages:
    55
    Likes Received:
    68
    • Helpful Helpful x 1
  19. TerryBalldriver

    TerryBalldriver Member

    Joined:
    Jan 12, 2019
    Messages:
    35
    Likes Received:
    26
    Watched some of the DTG NTP stream on YouTube with Jamie and Natalie. And even they seem to be having stutters. Example 45mins into stream. Didn't watch it all but they probably did not mention it!
     
    • Like Like x 1
  20. Thorgred

    Thorgred Member

    Joined:
    Jun 8, 2018
    Messages:
    55
    Likes Received:
    34
  21. geloxo

    geloxo Well-Known Member

    Joined:
    Nov 21, 2018
    Messages:
    499
    Likes Received:
    821
    I did some testing with multiple settings and to me, the combination of the following two factors is what really reduces the stuttering to the minimum:

    1) Enable DX12 in game launch options. Even if not officially supported by game it clearly improves performance.
    2) Disable texture streaming. The first scene loading after starting service takes a bit longer but once everything is stored in memory it works much more efficiently while driving.

    In particular, the combination of the two settings above together is what resolves the issue, and for some reason allows a much faster tile loading. Using one or the other alone provides no results. The remaining stuttering is linked to the new tile loading and this is hardly avoidable, as it´s how this game and most simulators load the content. If you find a tile containing a yard there´s for sure delay in loading it and therefore stuttering. This effect exists since Rail Simulator era, more than 10 years ago.

    My engine.ini settings:

    [SystemSettings]
    r.ViewDistanceScale=2 (increasing to higher values start to produce delays with tile loading)
    r.LandscapeLODDistributionScale=4 (avoid terrain covering tracks/tunnels. It seems 2 or 3 are hardcoded max values)
    r.StaticMeshLODDistanceScale=0.25 (even if being a extreme setting it avoids many drawing artifacts at medium distances)
    foliage.LODDistanceScale=4 (avoids trees pop-in effect)
    r.Shadow.DistanceScale=4 (placebo, left just in case. It seems max limit is hardcoded in game. You can only reduce distance)
    r.MotionBlurQuality=0 (diable motion blur as there´s a bug in settings and it is not disabled in UI)
    r.TextureStreaming=0 (loads all scene and allows textures in max resolution, preventing blurry textures at medium distances too)

    My specs:

    i9900k + 2080Ti + 32 Gb RAM + Samsung 860 Evo 1TB SSD

    The above specs produce a reduced performance loss but greatly improve visuals and stability. Last test I did produced 60 FPS peak when exiting Hagen yard and 80 FPS peak on main line in the RRO route, with 1080p resolution and 200% scaling. And as average I stay on 60-70 FPS while driving which is by far more than what is needed for a smooth gameplay.

    Going higher than this, specially with viewdistance, can improve visuals in open valley areas, but starts to put my system to its knees at yards, as much more data is required to be loaded at once. Increasing the LODs variables does not seem to produce a noticeable effect either, so maybe I´m already at the possible max limits I can set. Even r.ViewDistanceScale appears to be not doing anything above the x3 value. At least I didn´t see any improvement when setting it on x4 or x5 values.

    Cheers
     
    Last edited: Nov 17, 2020
    • Like Like x 2
    • Helpful Helpful x 1
  22. Quentin

    Quentin Active Member

    Joined:
    Dec 8, 2016
    Messages:
    108
    Likes Received:
    92
    Thanks geloxo, but when I disable texture streaming, it takes nearly 3 minutes (rather than 20-30 secs) to load each activity, which is too long for me. The other settings work nicely on my system (running with DX12 and 4K Ultra settings at 100%):
    i4790K + 2070 +16GB + Seagate KINGSTON SHSS37A 480GB SSD
     
  23. geloxo

    geloxo Well-Known Member

    Joined:
    Nov 21, 2018
    Messages:
    499
    Likes Received:
    821
  24. londonmidland

    londonmidland Well-Known Member

    Joined:
    Nov 8, 2017
    Messages:
    1,350
    Likes Received:
    5,002
    Something about TSW 2 is causing me inferior performance compared to TSW 1. Even with no ini settings, there are some ridiculous amounts of stutters and inconsistent fps.

    It's almost as TSW 2 hasn't been optimised properly.
     
    • Like Like x 2
  25. londonmidland

    londonmidland Well-Known Member

    Joined:
    Nov 8, 2017
    Messages:
    1,350
    Likes Received:
    5,002
    Has anyone noticed in any of the livestreams apparent stuttering? In a recent GWE live stream it was quite obvious.
     
    • Like Like x 1
  26. TerryBalldriver

    TerryBalldriver Member

    Joined:
    Jan 12, 2019
    Messages:
    35
    Likes Received:
    26
    I posted a comment in this thread the other week after watching a DTG NTP stream. They never seem to acknowledge the stutters as far as I know.
     
    • Like Like x 1
  27. londonmidland

    londonmidland Well-Known Member

    Joined:
    Nov 8, 2017
    Messages:
    1,350
    Likes Received:
    5,002
    Pretty poor as they know it's an issue, but they aren't doing anything to acknowledge it and instead ignore it.
     
    • Like Like x 3
  28. dhekelian

    dhekelian Member

    Joined:
    Nov 24, 2020
    Messages:
    77
    Likes Received:
    56
    I too had noticed stuttering in their videos. Is it on their roadmap or are they ignoring it as you say?
     
  29. londonmidland

    londonmidland Well-Known Member

    Joined:
    Nov 8, 2017
    Messages:
    1,350
    Likes Received:
    5,002
    I’ve noticed this too in the livestream videos and it seems they’re choosing to ignore it or perhaps not say anything about it, hoping no one will notice. There’s also nothing on the roadmap about it.
     
  30. maxipolo12

    maxipolo12 Active Member

    Joined:
    Apr 24, 2020
    Messages:
    245
    Likes Received:
    213
    and you will never see it because core problem of the game (assets) ;)
     
    • Like Like x 1
  31. michael hooley

    michael hooley Well-Known Member

    Joined:
    Dec 11, 2016
    Messages:
    271
    Likes Received:
    266
    I hope what you say is not true, I have spent hours and a fortune trying to improve the performance of TSW2, the latest update has just ended about 6 weeks of faultless performance (apart from the stutters) now the frame rate on the Manchester to Leeds route has dropped from about 60fpm to 19fpm.

    Last night I ran the oil tankers Staylybridge to Hudderfield service on TSW2 the frame rate never got above 9fpm and got an unreal 4 engine crash halfway through

    I ran the same service on TSW2020, the frame rate was about 60fps but got a blue screen of death after about 10 mins.

    I am now waiting for a response from my ticket.

    I cannot believe this is just coincidence just hours after the last update.

    Mike
     
    • Like Like x 1
  32. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    1,312
    Likes Received:
    2,722
    Mike, I know it’s a long shot, but your PC hasn’t defaulted to using integrated graphics rather than your GPU has it

    What you’re experiencing sounds very odd indeed.
     
  33. michael hooley

    michael hooley Well-Known Member

    Joined:
    Dec 11, 2016
    Messages:
    271
    Likes Received:
    266
    That was the first thing I checked, no still on high performance, I have had an answer with a checklist from DTG first thing is to check all your drivers are up to date, that is a nightmare in itself, I have paid £20 for a years subscription to Driver Genius Pro. not sure if it is worth it but it found 11 drivers that needed updating. done that now we will see if it helps.

    Thank You Hightower

    Mike
     
    • Like Like x 1
  34. michael hooley

    michael hooley Well-Known Member

    Joined:
    Dec 11, 2016
    Messages:
    271
    Likes Received:
    266
    Well I have solved the Frame rate problem, for some reason my screen res in TSW 2 had changed from my usual 1920x1080 to 4096x2160 when reverted back my frame rate is now 50/60.
     
    • Like Like x 1
  35. hightower

    hightower Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    1,312
    Likes Received:
    2,722
    Excellent news! :)
     
    • Like Like x 1
  36. Hatter

    Hatter New Member

    Joined:
    Dec 5, 2019
    Messages:
    19
    Likes Received:
    2
    Hi, purchased Tees Valley yesterday and it really stutters and hangs.
    In the 08 cab, get in and walk across to switch the markers and instrument lights on and it then just hangs. Can't get to the seat to sit down or do anything. Also when walking outside, just stops for about 5-10 seconds (sometimes even longer).
    All other routes work ok (including the preserved I've got).
    Hope it gets fixed soon.
     
    • Like Like x 1
  37. geloxo

    geloxo Well-Known Member

    Joined:
    Nov 21, 2018
    Messages:
    499
    Likes Received:
    821
    If you have NVIDIA card you can customize the NVIDIA game profile with this: Anti-stuttering Trick: Force Game To Render At A Fixed Fps Target | Dovetail Games Forums

    I found that running at 48fps (1/3 refresh rate for 144Hz) results in almost no stuttering, except the one related to tile loading. Depending of your system you can even try 60fps as well (1/2 of 120Hz). To reduce the tile loading one try not to push the viewdistance too much as this forces more content to be loaded at once. Indeed most routes do not seem to render anything extra above x3 viewdistances.

    I use the following settings including DX12 mode and Tees Valley runs very well, even at the yard:

    [SystemSettings]
    r.Shadow.DistanceScale=2
    r.ViewDistanceScale=2
    r.LandscapeLOD0DistributionScale=3
    r.StaticMeshLODDistanceScale=0.25
    foliage.LODDistanceScale=4
    r.TextureStreaming=0

    I didn´t found any issues on other routes using those settings. All run excelent with them.

    Cheers
     
    Last edited: Dec 1, 2020
    • Like Like x 1
    • Helpful Helpful x 1
  38. Hatter

    Hatter New Member

    Joined:
    Dec 5, 2019
    Messages:
    19
    Likes Received:
    2
    Hi, thanks for the info but have an AMD Radeon card. The machine needs upgrading (just above minimum specs atm) but it has run TSW2 okay so far, only issue is after getting Tees Valley, but seems I'm not alone.
     
  39. 4-COR

    4-COR Well-Known Member

    Joined:
    Jul 19, 2019
    Messages:
    197
    Likes Received:
    309
    Stuttering is terrible on the high speed routes, and I doubt LGV is going to make it any better
     
    • Like Like x 1
  40. ht-57

    ht-57 Member

    Joined:
    Jan 6, 2018
    Messages:
    56
    Likes Received:
    37
    geloxo,
    TYVM for sharing your settings, as well as your findings with the different .ini settings
     
  41. maxipolo12

    maxipolo12 Active Member

    Joined:
    Apr 24, 2020
    Messages:
    245
    Likes Received:
    213
    That simply ruins the gaming experience.
    And when you talk to stuttering to people they say they are not any stuttering :D
    And the devs ask you at which moment do you see stuttering :D :D whereas its all along the track ..
     
    • Like Like x 3
  42. Tom0604

    Tom0604 New Member

    Joined:
    Jan 2, 2021
    Messages:
    2
    Likes Received:
    1
    Same for me with 10900k 5.2 ghz stable, 2080ti 32 gigs of ram 4000mhz - loading stutters on all routes- breaking the immersion for me totally. It ruins this game, seriously. DTG please fix this issue and yes i got ssd samsung evo pro series. MSFS 2k20 for example is so smooth no stutters, learn from them and they just released it months ago and you were in development for years.Years for years this scenery loading stutter issues.
    Until they fix it, i won‘t buy anything from them- sad, but true.
     
    Last edited: Jan 2, 2021
  43. maxipolo12

    maxipolo12 Active Member

    Joined:
    Apr 24, 2020
    Messages:
    245
    Likes Received:
    213
    You can have a 10000€ config you will always have stuttering cause of bad optimization.
    Nothing to do
     
    • Like Like x 1
  44. Crosstie

    Crosstie Well-Known Member

    Joined:
    Dec 8, 2016
    Messages:
    452
    Likes Received:
    652
    This is a tricky problem for DTG or any game publisher. There are people with very high end systems who experience stuttering and other graphics issues. But there are many others with very modest configurations, like myself, who do not. PC's are like fingerprints - no two are alike and everyone has different settings and background software. So what are DTG to do? Customize the game engine for each individual? Sorry, but, if you have a powerful system and TSW2 doesn't run well, it's not the game that's at fault. Sure it could stand some bug fixes and improvements, but, for the most part, it will run OK with the recommended configuration. (Raises shield for backlash).
     
    Last edited: Jan 2, 2021
    • Like Like x 3
  45. michael hooley

    michael hooley Well-Known Member

    Joined:
    Dec 11, 2016
    Messages:
    271
    Likes Received:
    266
    You are correct Crosstie, the sim ran smoother on my lower spec desktop, but there must be a reason therefore a solution.

    Mike
     
    • Like Like x 1
  46. GrayDawg

    GrayDawg Active Member

    Joined:
    Dec 5, 2019
    Messages:
    131
    Likes Received:
    230
    If you have texture streaming disabled in the .ini file, that usually comes with a price tag, more load stutters. Enabling texture streaming removes just about all stutters for me even when in a TGV at full speed. I do disable texture streaming on slower paced routes, though, SPG etc. No need to disable it there, but as soon as you are on a route with high speed trains...well, try it. At least it helped me making LGV playable, instead of pure stuttering hell.
     
    • Like Like x 1
  47. Jack O'Track

    Jack O'Track Active Member

    Joined:
    Oct 29, 2019
    Messages:
    224
    Likes Received:
    82
    I have started using Windows LTSB 3 years ago, and now got LTSC.
    I get the strong impression that home and even pro are less suitable for higher frame rates ...
    9700k, 2080ti, 32GB ram, 4k monitor at 144kHz, and 120 fps ...
     
  48. zawal.belili

    zawal.belili Well-Known Member

    Joined:
    Apr 30, 2019
    Messages:
    132
    Likes Received:
    375
    I have the impression that everyone who uses RTX is having problems!
    I have an nvidia 970 and I play ultra on a 27 "screen at 1080p, I have between 30 and 80 fps without any stutter!
    Personally I will soon have a super 1660, I don't think I will switch to RTX for a very, very long time, I play mainly in 1080p and for me it would be stupid to buy a very (too) expensive CG for nothing.

    I add that I have not touched anything in the config file of course
     
  49. Callum B.

    Callum B. Well-Known Member

    Joined:
    Aug 9, 2018
    Messages:
    556
    Likes Received:
    926
    You have a good mentality. Many PC gamers (or enthusiasts) will quickly buy the next-best thing simply because it is shiny and new even if they are already satisfied with what they already have. The GTX cards (even the older ones) are still fine for 1080p gaming. The primary reason that I upgraded was because I had bought a newer, high-resolution monitor that only the RTX cards (or a 1080ti, if we're honest) could handle well. It is better for the environment and your wallet by holding onto your current tech if you're satisfied with the performance.

    Cheers
     
    • Like Like x 2
  50. Shaun123

    Shaun123 Well-Known Member

    Joined:
    Jan 22, 2018
    Messages:
    221
    Likes Received:
    414
    I recently bought a RTX 2080 Super, it's night and day compared to my old Radeon RX580, and runs the game impressively. My monitor 27" 1440p overclocked to 165hz.

    I noticed since the update, and see my post in the initial LGV review thread, about issues the first time I ran the route, that I was suffering a lot of stutters on LGV since the update the other day.
     

Share This Page